Update to version 0.8.31; Fixes RHBZ#2030275

epel9
Fabio Valentini 3 years ago
parent ff2a07f0fe
commit b70f35980d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -21,3 +21,4 @@
/encoding_rs-0.8.26.crate /encoding_rs-0.8.26.crate
/encoding_rs-0.8.28.crate /encoding_rs-0.8.28.crate
/encoding_rs-0.8.29.crate /encoding_rs-0.8.29.crate
/encoding_rs-0.8.31.crate

@ -1,12 +1,17 @@
--- encoding_rs-0.8.29/Cargo.toml 1970-01-01T00:00:01+00:00 --- encoding_rs-0.8.31/Cargo.toml 1970-01-01T00:00:01+00:00
+++ encoding_rs-0.8.29/Cargo.toml 2021-11-06T14:23:45.613518+00:00 +++ encoding_rs-0.8.31/Cargo.toml 2022-05-13T20:36:26.125055+00:00
@@ -22,15 +22,11 @@ @@ -32,17 +32,16 @@
categories = ["text-processing", "encoding", "web-programming", "internationalization"] ]
license = "Apache-2.0 OR MIT" license = "(Apache-2.0 OR MIT) AND BSD-3-Clause"
repository = "https://github.com/hsivonen/encoding_rs" repository = "https://github.com/hsivonen/encoding_rs"
+exclude = ["/generate-encoding-data.py"] +exclude = [
+ "/generate-encoding-data.py",
+ "/rustfmt.toml",
+]
[profile.release] [profile.release]
lto = true lto = true
[dependencies.cfg-if] [dependencies.cfg-if]
version = "1.0" version = "1.0"
- -
@ -17,10 +22,14 @@
[dependencies.serde] [dependencies.serde]
version = "1.0" version = "1.0"
@@ -56,6 +52,5 @@ @@ -75,10 +74,6 @@
less-slow-big5-hanzi-encode = [] less-slow-big5-hanzi-encode = []
less-slow-gb-hanzi-encode = [] less-slow-gb-hanzi-encode = []
less-slow-kanji-encode = [] less-slow-kanji-encode = []
-simd-accel = ["packed_simd", "packed_simd/into_bits"] -simd-accel = [
- "packed_simd",
- "packed_simd/into_bits",
-]
[badges.travis-ci] [badges.travis-ci]
repository = "hsivonen/encoding_rs" repository = "hsivonen/encoding_rs"

@ -1,16 +1,18 @@
# Generated by rust2rpm 18 # Generated by rust2rpm 21
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate encoding_rs %global crate encoding_rs
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.8.29 Version: 0.8.31
Release: %autorelease Release: %autorelease
Summary: Gecko-oriented implementation of the Encoding Standard Summary: Gecko-oriented implementation of the Encoding Standard
# Upstream license specification: Apache-2.0 OR MIT # Upstream license specification: (Apache-2.0 OR MIT) AND BSD-3-Clause
License: ASL 2.0 or MIT # * source code: ASL 2.0 or MIT
# * source code derived from the WHATWG Encoding Standard: BSD 3-Clause License
License: (ASL 2.0 or MIT) and BSD
URL: https://crates.io/crates/encoding_rs URL: https://crates.io/crates/encoding_rs
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
@ -19,11 +21,8 @@ Source: %{crates_source}
Patch0: encoding_rs-fix-metadata.diff Patch0: encoding_rs-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Gecko-oriented implementation of the Encoding Standard.} Gecko-oriented implementation of the Encoding Standard.}
@ -36,13 +35,18 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license COPYRIGHT LICENSE-MIT LICENSE-APACHE %license %{crate_instdir}/COPYRIGHT
%doc README.md %license %{crate_instdir}/LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %license %{crate_instdir}/LICENSE-MIT
%license %{crate_instdir}/LICENSE-WHATWG
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/Ideas.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -50,11 +54,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel %package -n %{name}+alloc-devel
Summary: %{summary} Summary: %{summary}
@ -62,11 +66,11 @@ BuildArch: noarch
%description -n %{name}+alloc-devel %{_description} %description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "alloc" feature of "%{crate}" crate. use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel %files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fast-big5-hanzi-encode-devel %package -n %{name}+fast-big5-hanzi-encode-devel
Summary: %{summary} Summary: %{summary}
@ -74,11 +78,11 @@ BuildArch: noarch
%description -n %{name}+fast-big5-hanzi-encode-devel %{_description} %description -n %{name}+fast-big5-hanzi-encode-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "fast-big5-hanzi-encode" feature of "%{crate}" crate. use the "fast-big5-hanzi-encode" feature of the "%{crate}" crate.
%files -n %{name}+fast-big5-hanzi-encode-devel %files -n %{name}+fast-big5-hanzi-encode-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fast-gb-hanzi-encode-devel %package -n %{name}+fast-gb-hanzi-encode-devel
Summary: %{summary} Summary: %{summary}
@ -86,11 +90,11 @@ BuildArch: noarch
%description -n %{name}+fast-gb-hanzi-encode-devel %{_description} %description -n %{name}+fast-gb-hanzi-encode-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "fast-gb-hanzi-encode" feature of "%{crate}" crate. use the "fast-gb-hanzi-encode" feature of the "%{crate}" crate.
%files -n %{name}+fast-gb-hanzi-encode-devel %files -n %{name}+fast-gb-hanzi-encode-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fast-hangul-encode-devel %package -n %{name}+fast-hangul-encode-devel
Summary: %{summary} Summary: %{summary}
@ -98,11 +102,11 @@ BuildArch: noarch
%description -n %{name}+fast-hangul-encode-devel %{_description} %description -n %{name}+fast-hangul-encode-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "fast-hangul-encode" feature of "%{crate}" crate. use the "fast-hangul-encode" feature of the "%{crate}" crate.
%files -n %{name}+fast-hangul-encode-devel %files -n %{name}+fast-hangul-encode-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fast-hanja-encode-devel %package -n %{name}+fast-hanja-encode-devel
Summary: %{summary} Summary: %{summary}
@ -110,11 +114,11 @@ BuildArch: noarch
%description -n %{name}+fast-hanja-encode-devel %{_description} %description -n %{name}+fast-hanja-encode-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "fast-hanja-encode" feature of "%{crate}" crate. use the "fast-hanja-encode" feature of the "%{crate}" crate.
%files -n %{name}+fast-hanja-encode-devel %files -n %{name}+fast-hanja-encode-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fast-kanji-encode-devel %package -n %{name}+fast-kanji-encode-devel
Summary: %{summary} Summary: %{summary}
@ -122,11 +126,11 @@ BuildArch: noarch
%description -n %{name}+fast-kanji-encode-devel %{_description} %description -n %{name}+fast-kanji-encode-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "fast-kanji-encode" feature of "%{crate}" crate. use the "fast-kanji-encode" feature of the "%{crate}" crate.
%files -n %{name}+fast-kanji-encode-devel %files -n %{name}+fast-kanji-encode-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fast-legacy-encode-devel %package -n %{name}+fast-legacy-encode-devel
Summary: %{summary} Summary: %{summary}
@ -134,11 +138,11 @@ BuildArch: noarch
%description -n %{name}+fast-legacy-encode-devel %{_description} %description -n %{name}+fast-legacy-encode-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "fast-legacy-encode" feature of "%{crate}" crate. use the "fast-legacy-encode" feature of the "%{crate}" crate.
%files -n %{name}+fast-legacy-encode-devel %files -n %{name}+fast-legacy-encode-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+less-slow-big5-hanzi-encode-devel %package -n %{name}+less-slow-big5-hanzi-encode-devel
Summary: %{summary} Summary: %{summary}
@ -146,11 +150,11 @@ BuildArch: noarch
%description -n %{name}+less-slow-big5-hanzi-encode-devel %{_description} %description -n %{name}+less-slow-big5-hanzi-encode-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "less-slow-big5-hanzi-encode" feature of "%{crate}" crate. use the "less-slow-big5-hanzi-encode" feature of the "%{crate}" crate.
%files -n %{name}+less-slow-big5-hanzi-encode-devel %files -n %{name}+less-slow-big5-hanzi-encode-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+less-slow-gb-hanzi-encode-devel %package -n %{name}+less-slow-gb-hanzi-encode-devel
Summary: %{summary} Summary: %{summary}
@ -158,11 +162,11 @@ BuildArch: noarch
%description -n %{name}+less-slow-gb-hanzi-encode-devel %{_description} %description -n %{name}+less-slow-gb-hanzi-encode-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "less-slow-gb-hanzi-encode" feature of "%{crate}" crate. use the "less-slow-gb-hanzi-encode" feature of the "%{crate}" crate.
%files -n %{name}+less-slow-gb-hanzi-encode-devel %files -n %{name}+less-slow-gb-hanzi-encode-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+less-slow-kanji-encode-devel %package -n %{name}+less-slow-kanji-encode-devel
Summary: %{summary} Summary: %{summary}
@ -170,11 +174,11 @@ BuildArch: noarch
%description -n %{name}+less-slow-kanji-encode-devel %{_description} %description -n %{name}+less-slow-kanji-encode-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "less-slow-kanji-encode" feature of "%{crate}" crate. use the "less-slow-kanji-encode" feature of the "%{crate}" crate.
%files -n %{name}+less-slow-kanji-encode-devel %files -n %{name}+less-slow-kanji-encode-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
@ -182,11 +186,11 @@ BuildArch: noarch
%description -n %{name}+serde-devel %{_description} %description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "serde" feature of "%{crate}" crate. use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (encoding_rs-0.8.29.crate) = d5d2d476d4093c16514a8a0d9f363c24c766d565d45d1b2b21e97bdb6caac6050552815c9d96fb652c9516a41368f99e3a893e42c1884cd989c1e00de0ded587 SHA512 (encoding_rs-0.8.31.crate) = a9e582ab63d00bfd17c9f813f886c5908279fe4d23cdd70f79580931f3a0479162b78210a27b113a7bf6fbc4f8d62bbf098ef645d598fe0eaa428639c35cec31

Loading…
Cancel
Save