parent
e1505f18ca
commit
1d3d21acdc
@ -0,0 +1 @@
|
|||||||
|
/encoding_rs-0.7.1.crate
|
@ -0,0 +1,21 @@
|
|||||||
|
--- encoding_rs-0.7.1/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ encoding_rs-0.7.1/Cargo.toml 2017-11-13T19:15:46.593464+01:00
|
||||||
|
@@ -28,10 +28,6 @@
|
||||||
|
version = "1.0"
|
||||||
|
optional = true
|
||||||
|
|
||||||
|
-[dependencies.simd]
|
||||||
|
-version = "0.2.0"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
[dependencies.cfg-if]
|
||||||
|
version = "0.1.0"
|
||||||
|
[dev-dependencies.serde_derive]
|
||||||
|
@@ -44,7 +40,6 @@
|
||||||
|
version = "0.8"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
-simd-accel = ["simd"]
|
||||||
|
no-static-ideograph-encoder-tables = []
|
||||||
|
[badges.travis-ci]
|
||||||
|
repository = "hsivonen/encoding_rs"
|
@ -0,0 +1,77 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate encoding_rs
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.7.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Gecko-oriented implementation of the Encoding Standard
|
||||||
|
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/encoding_rs
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * No simd
|
||||||
|
Patch0: encoding_rs-0.7.1-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(cfg-if) >= 0.1.0 with crate(cfg-if) < 0.2.0)
|
||||||
|
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
|
||||||
|
%if %{with check}
|
||||||
|
# [dev-dependencies]
|
||||||
|
BuildRequires: (crate(bincode) >= 0.8.0 with crate(bincode) < 0.9.0)
|
||||||
|
BuildRequires: (crate(serde_derive) >= 1.0.0 with crate(serde_derive) < 2.0.0)
|
||||||
|
BuildRequires: (crate(serde_json) >= 1.0.0 with crate(serde_json) < 2.0.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
A Gecko-oriented implementation of the Encoding Standard.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license COPYRIGHT LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc README.md CONTRIBUTING.md Ideas.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
%exclude %{cargo_registry}/%{crate}-%{version}/generate-encoding-data.py*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Nov 13 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-1
|
||||||
|
- Update to 0.7.1
|
||||||
|
|
||||||
|
* Thu Jun 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.11-1
|
||||||
|
- Update to 0.6.11
|
||||||
|
|
||||||
|
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-2
|
||||||
|
- Port to use rust-packaging
|
||||||
|
|
||||||
|
* Wed Mar 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue