import rust-ed25519-compact-2.1.1-2.el10

i10ce changed/i10ce/rust-ed25519-compact-2.1.1-2.el10
MSVSphere Packaging Team 2 months ago
commit 17422eb4ef
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/ed25519-compact-2.1.1.crate

@ -0,0 +1 @@
18d288fff82e70db486bf9c93da08d76db9625a5 SOURCES/ed25519-compact-2.1.1.crate

@ -0,0 +1,22 @@
--- ed25519-compact-2.1.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ed25519-compact-2.1.1/Cargo.toml 2024-05-01T15:12:23.534667+00:00
@@ -61,18 +61,10 @@
traits = ["ed25519"]
x25519 = []
-[target."cfg(all(any(target_arch = \"wasm32\", target_arch = \"wasm64\"), target_os = \"unknown\"))".dependencies.getrandom]
-version = "0.2"
-features = ["js"]
-optional = true
-
-[target."cfg(all(any(target_arch = \"wasm32\", target_arch = \"wasm64\"), target_os = \"unknown\"))".dev-dependencies.getrandom]
-version = "0.2"
-features = ["js"]
-
[target."cfg(not(all(any(target_arch = \"wasm32\", target_arch = \"wasm64\"), target_os = \"unknown\")))".dependencies.getrandom]
version = "0.2"
optional = true
[target."cfg(not(all(any(target_arch = \"wasm32\", target_arch = \"wasm64\"), target_os = \"unknown\")))".dev-dependencies.getrandom]
version = "0.2"
+

@ -0,0 +1,245 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.2)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 2;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate ed25519-compact
Name: rust-ed25519-compact
Version: 2.1.1
Release: %autorelease
Summary: Small, self-contained, wasm-friendly Ed25519 implementation
License: MIT
URL: https://crates.io/crates/ed25519-compact
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: ed25519-compact-fix-metadata-auto.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A small, self-contained, wasm-friendly Ed25519 implementation.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+blind-keys-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+blind-keys-devel %{_description}
This package contains library source intended for building other packages which
use the "blind-keys" feature of the "%{crate}" crate.
%files -n %{name}+blind-keys-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ct-codecs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ct-codecs-devel %{_description}
This package contains library source intended for building other packages which
use the "ct-codecs" feature of the "%{crate}" crate.
%files -n %{name}+ct-codecs-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+disable-signatures-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+disable-signatures-devel %{_description}
This package contains library source intended for building other packages which
use the "disable-signatures" feature of the "%{crate}" crate.
%files -n %{name}+disable-signatures-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ed25519-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ed25519-devel %{_description}
This package contains library source intended for building other packages which
use the "ed25519" feature of the "%{crate}" crate.
%files -n %{name}+ed25519-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+getrandom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+getrandom-devel %{_description}
This package contains library source intended for building other packages which
use the "getrandom" feature of the "%{crate}" crate.
%files -n %{name}+getrandom-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+opt_size-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+opt_size-devel %{_description}
This package contains library source intended for building other packages which
use the "opt_size" feature of the "%{crate}" crate.
%files -n %{name}+opt_size-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pem-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pem-devel %{_description}
This package contains library source intended for building other packages which
use the "pem" feature of the "%{crate}" crate.
%files -n %{name}+pem-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+random-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+random-devel %{_description}
This package contains library source intended for building other packages which
use the "random" feature of the "%{crate}" crate.
%files -n %{name}+random-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+self-verify-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+self-verify-devel %{_description}
This package contains library source intended for building other packages which
use the "self-verify" feature of the "%{crate}" crate.
%files -n %{name}+self-verify-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+traits-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+traits-devel %{_description}
This package contains library source intended for building other packages which
use the "traits" feature of the "%{crate}" crate.
%files -n %{name}+traits-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+x25519-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+x25519-devel %{_description}
This package contains library source intended for building other packages which
use the "x25519" feature of the "%{crate}" crate.
%files -n %{name}+x25519-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 2.1.1-2
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Wed May 01 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.1-1
- Update to version 2.1.1; Fixes RHBZ#2262702
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.6-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Thu Jan 11 2024 Fabio Valentini <decathorpe@gmail.com> - 2.0.6-1
- Update to version 2.0.6; Fixes RHBZ#2254782
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Tue Jun 13 2023 Fabio Valentini <decathorpe@gmail.com> - 2.0.4-1
- Initial import (#2210896)
## END: Generated by rpmautospec
Loading…
Cancel
Save