Update to version 2.20.1; Fixes RHBZ#2125945

epel9 imports/e9/rust-dua-cli-2.20.1-1.el9
Fabio Valentini 1 year ago
parent 56c7f6d36f
commit 311278f1fc
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -14,3 +14,4 @@
/dua-cli-2.11.1.crate /dua-cli-2.11.1.crate
/dua-cli-2.17.0.crate /dua-cli-2.17.0.crate
/dua-cli-2.17.8.crate /dua-cli-2.17.8.crate
/dua-cli-2.20.1.crate

@ -1,75 +0,0 @@
ASL 2.0 or MIT: rust-autocfg 1.1.0
ASL 2.0 or MIT: rust-indexmap 1.9.1
ASL 2.0 or MIT: rust-parking_lot0.11 0.11.2
ASL 2.0 or MIT: rust-parking_lot_core0.8 0.8.5
ASL 2.0 or MIT: rust-signal-hook 0.3.14
ASL 2.0 or MIT: rust-signal-hook-mio 0.2.3
ASL 2.0 or MIT: rust-signal-hook-registry 1.4.0
ASL 2.0 or MIT: rust-wild 2.0.4
BSD: rust-instant 0.1.12
MIT or ASL 2.0 or zlib: rust-tinyvec_macros 0.1.0
MIT or ASL 2.0: rust-anyhow 1.0.58
MIT or ASL 2.0: rust-bitflags 1.3.2
MIT or ASL 2.0: rust-cassowary 0.3.0
MIT or ASL 2.0: rust-cfg-if 1.0.0
MIT OR ASL 2.0: rust-clap 3.2.12
MIT or ASL 2.0: rust-clap_derive 3.2.7
MIT or ASL 2.0: rust-clap_lex 0.2.4
MIT or ASL 2.0: rust-crossbeam 0.8.1
MIT or ASL 2.0: rust-crossbeam-channel 0.5.5
MIT or ASL 2.0: rust-crossbeam-deque 0.8.1
MIT or ASL 2.0: rust-crossbeam-epoch 0.9.9
MIT or ASL 2.0: rust-crossbeam-queue 0.3.5
MIT or ASL 2.0: rust-crossbeam-utils 0.8.10
MIT or ASL 2.0: rust-either 1.7.0
MIT or ASL 2.0: rust-fixedbitset 0.4.2
MIT or ASL 2.0: rust-form_urlencoded 1.0.1
MIT or ASL 2.0: rust-hashbrown 0.12.3
MIT or ASL 2.0: rust-heck 0.4.0
MIT or ASL 2.0: rust-idna 0.2.3
MIT or ASL 2.0: rust-itertools 0.10.3
MIT or ASL 2.0: rust-lazy_static 1.4.0
MIT or ASL 2.0: rust-libc 0.2.126
MIT or ASL 2.0: rust-lock_api 0.4.7
MIT or ASL 2.0: rust-log 0.4.17
MIT or ASL 2.0: rust-num_cpus 1.13.1
MIT or ASL 2.0: rust-once_cell 1.13.0
MIT or ASL 2.0: rust-os_str_bytes 6.1.0
MIT or ASL 2.0: rust-pathdiff 0.2.1
MIT or ASL 2.0: rust-percent-encoding 2.1.0
MIT or ASL 2.0: rust-petgraph 0.6.2
MIT or ASL 2.0: rust-proc-macro-error 1.0.4
MIT or ASL 2.0: rust-proc-macro-error-attr 1.0.4
MIT or ASL 2.0: rust-proc-macro2 1.0.40
MIT or ASL 2.0: rust-quote 1.0.20
MIT or ASL 2.0: rust-rayon 1.5.3
MIT or ASL 2.0: rust-rayon-core 1.9.3
MIT or ASL 2.0: rust-scopeguard 1.1.0
MIT or ASL 2.0: rust-smallvec 1.9.0
MIT or ASL 2.0: rust-syn 1.0.98
MIT or ASL 2.0: rust-unicode-bidi 0.3.8
MIT or ASL 2.0: rust-unicode-ident 1.0.1
MIT or ASL 2.0: rust-unicode-normalization 0.1.21
MIT or ASL 2.0: rust-unicode-segmentation 1.9.0
MIT or ASL 2.0: rust-unicode-width 0.1.9
MIT or ASL 2.0: rust-url 2.2.2
MIT or ASL 2.0: rust-version_check 0.9.4
MIT: rust-atty 0.2.14
MIT: rust-byte-unit 4.0.14
MIT: rust-crossterm 0.22.1
MIT: rust-crosstermion 0.9.0
MIT: rust-filesize 0.2.0
MIT: rust-jwalk 0.6.0
MIT: rust-matches 0.1.9
MIT: rust-memoffset 0.6.5
MIT: rust-mio0.7 0.7.14
MIT: rust-open 3.0.2
MIT: rust-strsim 0.10.0
MIT: rust-textwrap 0.15.0
MIT: rust-trash 2.1.5
MIT: rust-tui 0.17.0
MIT: rust-tui-react 0.17.0
MIT: rust-utf8-width 0.1.6
MPLv2.0: rust-colored 2.0.0
Unlicense or MIT: rust-termcolor 1.1.3
zlib or ASL 2.0 or MIT: rust-tinyvec 1.6.0

@ -1,3 +0,0 @@
# rust-dua-cli
The rust-dua-cli package

@ -1,6 +1,6 @@
--- a/Cargo.toml --- dua-cli-2.20.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ b/Cargo.toml +++ dua-cli-2.20.1/Cargo.toml 2023-07-21T18:29:52.618671+00:00
@@ -78,7 +78,7 @@ version = "0.6.0" @@ -75,7 +75,7 @@
version = "1.10.0" version = "1.10.0"
[dependencies.open] [dependencies.open]
@ -8,12 +8,4 @@
+version = "4.0" +version = "4.0"
optional = true optional = true
[dependencies.petgraph] [dependencies.owo-colors]
@@ -129,7 +129,3 @@ tui-unix = [
"crosstermion/tui-react-termion",
"tui-shared",
]
-
-[target."cfg(all(target_os = \"macos\", target_arch = \"aarch64\"))".dependencies.sysinfo]
-version = "0.23.2"
-default-features = false

@ -1,44 +1,37 @@
# Generated by rust2rpm 21 # Generated by rust2rpm 24
# * neither test files nor test code is included in published crates # * neither test files nor test code is included in published crates
%bcond_with check %bcond_with check
%global crate dua-cli %global crate dua-cli
Name: rust-%{crate} Name: rust-dua-cli
Version: 2.17.8 Version: 2.20.1
Release: %autorelease Release: %autorelease
Summary: Tool to conveniently learn about the disk usage of directories Summary: Tool to conveniently learn about the disk usage of directories
# Upstream license specification: MIT
License: MIT License: MIT
URL: https://crates.io/crates/dua-cli URL: https://crates.io/crates/dua-cli
Source0: %{crates_source} Source: %{crates_source}
Source1: LICENSE.dependencies # Manually created patch for downstream crate metadata changes
# Initial patched metadata # * bump open dependency from 3.0 to 4.0
# * drop macos-specific dependencies Patch: dua-cli-fix-metadata.diff
# * bump open from 3.0 to 4.0
Patch0: dua-cli-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: rust-packaging >= 23
BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Tool to conveniently learn about the disk usage of directories, fast!.} A tool to conveniently learn about the disk usage of directories, fast!.}
%description %{_description} %description %{_description}
%package -n %{crate} %package -n %{crate}
Summary: %{summary} Summary: %{summary}
# ASL 2.0 or MIT # Apache-2.0 OR MIT
# BSD # Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
# MIT # MIT
# MIT or ASL 2.0 # MIT OR Apache-2.0
# MIT or ASL 2.0 or zlib # MIT OR Apache-2.0 OR Zlib
# MPLv2.0 # Zlib OR Apache-2.0 OR MIT
# Unlicense or MIT License: MIT AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (MIT OR Apache-2.0 OR Zlib)
# zlib or ASL 2.0 or MIT
License: MIT and BSD and MPLv2.0
# LICENSE.dependencies contains a full license breakdown # LICENSE.dependencies contains a full license breakdown
%description -n %{crate} %{_description} %description -n %{crate} %{_description}
@ -199,7 +192,6 @@ use the "unicode-segmentation" feature of the "%{crate}" crate.
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
cp %{SOURCE1} .
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires
@ -207,6 +199,8 @@ cp %{SOURCE1} .
%build %build
%cargo_build %cargo_build
%cargo_license_summary
%{cargo_license} > LICENSE.dependencies
%install %install
%cargo_install %cargo_install

@ -0,0 +1,2 @@
[DEFAULT]
summary = Tool to conveniently learn about the disk usage of directories

@ -1 +1 @@
SHA512 (dua-cli-2.17.8.crate) = 5bf3c0445f6c351cdd242b2e62665660624941b409f1d8c68fc7c658e4d68c554753b31707644762108cb3eeecd8b15af11b953cd035671768bf7fe456f0fbf5 SHA512 (dua-cli-2.20.1.crate) = a1d0c292f0a638cb3e258a61eff0c3fb5bbe4110ef6da24bcbd021e70c10b4e1f310f5920f0addd92b9a2d86d390083363b0ab5884848a7bd8de8534530acc33

Loading…
Cancel
Save