Initial import (#2238171)
parent
a6296a78b4
commit
23ce3e99c5
@ -0,0 +1 @@
|
|||||||
|
/document-features-0.2.7.crate
|
@ -1,3 +0,0 @@
|
|||||||
# rust-document-features
|
|
||||||
|
|
||||||
The rust-document-features package
|
|
@ -0,0 +1,11 @@
|
|||||||
|
--- document-features-0.2.7/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ document-features-0.2.7/Cargo.toml 2023-09-09T17:32:50.349542+00:00
|
||||||
|
@@ -32,7 +32,7 @@
|
||||||
|
proc-macro = true
|
||||||
|
|
||||||
|
[dependencies.litrs]
|
||||||
|
-version = "0.2.3"
|
||||||
|
+version = "0.4"
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
[features]
|
@ -0,0 +1,86 @@
|
|||||||
|
# Generated by rust2rpm 24
|
||||||
|
# * self-tests do not work with munged Cargo.toml from published crates
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate document-features
|
||||||
|
|
||||||
|
Name: rust-document-features
|
||||||
|
Version: 0.2.7
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Extract documentation for the feature flags from comments in Cargo.toml
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/document-features
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * bump litrs dependency from 0.2 to 0.4
|
||||||
|
Patch: document-features-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Extract documentation for the feature flags from comments in Cargo.toml.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+self-test-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+self-test-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "self-test" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+self-test-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue