parent
beca10cb5a
commit
daafc60b9d
@ -0,0 +1 @@
|
||||
/displaydoc-0.2.3.crate
|
@ -0,0 +1,11 @@
|
||||
--- displaydoc-0.2.3/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ displaydoc-0.2.3/Cargo.toml 2021-08-05T14:22:54.424920+00:00
|
||||
@@ -85,7 +85,7 @@
|
||||
version = "1.0.0"
|
||||
|
||||
[dev-dependencies.static_assertions]
|
||||
-version = "0.3.4"
|
||||
+version = "1.1"
|
||||
|
||||
[dev-dependencies.thiserror]
|
||||
version = "1.0.24"
|
@ -0,0 +1,91 @@
|
||||
# Generated by rust2rpm 18
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate displaydoc
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.2.3
|
||||
Release: %autorelease
|
||||
Summary: Derive macro for implementing the display Trait
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/displaydoc
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# Bump static_assertions to 1.1
|
||||
# https://github.com/yaahc/displaydoc/pull/34
|
||||
Patch0: displaydoc-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Derive macro for implementing the display Trait via a doc comment and string
|
||||
interpolation.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.md CHANGELOG.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "std" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue