parent
b610e2a3ff
commit
76c75776c1
@ -0,0 +1 @@
|
|||||||
|
/dirs-1.0.3.crate
|
@ -0,0 +1,9 @@
|
|||||||
|
--- dirs-1.0.3/Cargo.toml 1969-12-31T16:00:00-08:00
|
||||||
|
+++ dirs-1.0.3/Cargo.toml 2018-09-17T12:37:13.594613-07:00
|
||||||
|
@@ -21,6 +21,3 @@
|
||||||
|
repository = "https://github.com/soc/dirs-rs"
|
||||||
|
[target."cfg(unix)".dependencies.libc]
|
||||||
|
version = "0.2"
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.3"
|
||||||
|
-features = ["knownfolders", "objbase", "shlobj", "winbase", "winerror"]
|
@ -0,0 +1,65 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate dirs
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 1.0.3
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Platform abstractions for common directories
|
||||||
|
|
||||||
|
# Upstream license specification: MIT OR Apache-2.0
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/dirs
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * no windows deps
|
||||||
|
Patch0: dirs-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
A tiny low-level library that provides platform-specific standard locations of
|
||||||
|
directories for config, cache and other data on Linux, Windows and macOS by
|
||||||
|
leveraging the mechanisms defined by the XDG base/user directory specifications
|
||||||
|
on Linux, the Known Folder API on Windows, and the Standard Directory
|
||||||
|
guidelines on macOS.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-APACHE LICENSE-MIT
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Sep 18 2018 Josh Stone <jistone@redhat.com> - 1.0.3-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue