parent
014b43f97a
commit
6c1ee3867a
@ -0,0 +1 @@
|
|||||||
|
/dirs-sys-next-0.1.1.crate
|
@ -0,0 +1,16 @@
|
|||||||
|
--- dirs-sys-next-0.1.1/Cargo.toml 2020-10-13T09:20:23+00:00
|
||||||
|
+++ dirs-sys-next-0.1.1/Cargo.toml 2020-12-27T10:08:23.533872+00:00
|
||||||
|
@@ -19,13 +19,7 @@
|
||||||
|
readme = "README.md"
|
||||||
|
license = "MIT OR Apache-2.0"
|
||||||
|
repository = "https://github.com/xdg-rs/dirs/tree/master/dirs-sys"
|
||||||
|
-[target."cfg(target_os = \"redox\")".dependencies.redox_users]
|
||||||
|
-version = "0.3.0"
|
||||||
|
-default-features = false
|
||||||
|
[target."cfg(unix)".dependencies.libc]
|
||||||
|
version = "0.2"
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.3"
|
||||||
|
-features = ["knownfolders", "objbase", "shlobj", "winbase", "winerror"]
|
||||||
|
[badges.maintenance]
|
||||||
|
status = "as-is"
|
@ -0,0 +1,78 @@
|
|||||||
|
# Generated by rust2rpm 16
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate dirs-sys-next
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.1.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: System-level helper functions for the dirs and directories crates
|
||||||
|
|
||||||
|
# Upstream license specification: MIT OR Apache-2.0
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/dirs-sys-next
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * No windows/redox
|
||||||
|
Patch0: dirs-sys-next-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
System-level helper functions for the dirs and directories crates.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc README.md CHANGELOG.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Dec 27 11:08:23 CET 2020 Igor Raits <igor.raits@gmail.com> - 0.1.1-1
|
||||||
|
- Initial package (Closes: RHBZ#1911048)
|
Loading…
Reference in new issue