Update to 0.53.1

Signed-off-by: Michel Lind <salimma@fedoraproject.org>
epel9 imports/e9/rust-difftastic-0.53.1-1.el9
Michel Lind 1 year ago
parent 42f64534f1
commit d28800cec8
No known key found for this signature in database
GPG Key ID: 8B229D2F7CCC04F2

1
.gitignore vendored

@ -5,3 +5,4 @@
/difftastic-0.49.0.crate /difftastic-0.49.0.crate
/difftastic-0.50.0.crate /difftastic-0.50.0.crate
/difftastic-0.51.1.crate /difftastic-0.51.1.crate
/difftastic-0.53.1.crate

@ -1,26 +1,57 @@
--- difftastic-0.51.1/Cargo.toml 1970-01-01T00:00:01+00:00 --- difftastic-0.53.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ difftastic-0.51.1/Cargo.toml 2023-08-29T16:14:29.931618+00:00 +++ difftastic-0.53.1/Cargo.toml 2023-12-05T20:07:48.661991+00:00
@@ -66,7 +66,7 @@ @@ -54,7 +54,7 @@
path = "src/main.rs"
[dependencies.aho-corasick]
-version = ">= 1.0, < 1.1.0"
+version = "1"
[dependencies.bumpalo]
version = "3.11.1"
@@ -84,10 +84,10 @@
version = "2.1.3"
[dependencies.ignore]
-version = ">= 0.4, < 0.4.19"
+version = "0.4"
[dependencies.is-terminal]
-version = ">= 0.4, < 0.4.8"
+version = "0.4"
[dependencies.itertools]
version = "0.11.0"
@@ -99,7 +99,7 @@
version = "0.2.108" version = "0.2.108"
[dependencies.libmimalloc-sys] [dependencies.libmimalloc-sys]
-version = "=0.1.24" -version = "=0.1.24"
+version = "0.1.24" +version = "0.1.24"
[dependencies.log] [dependencies.line-numbers]
version = "0.3.0"
@@ -108,7 +108,7 @@
version = "0.4.14" version = "0.4.14"
@@ -88,7 +88,7 @@
[dependencies.memchr]
-version = ">= 2, < 2.6"
+version = "2"
[dependencies.mimalloc]
version = "0.1.28"
@@ -127,7 +127,7 @@
version = "1.7.0" version = "1.7.0"
[dependencies.regex] [dependencies.regex]
-version = ">= 1.7, < 1.8" -version = ">= 1.9, < 1.9.5"
+version = "1.7" +version = "1.9"
[dependencies.rustc-hash] [dependencies.rustc-hash]
version = "1.1.0" version = "1.1.0"
@@ -125,10 +125,10 @@ @@ -162,10 +162,10 @@
[dependencies.wu-diff]
version = "0.1.2" version = "0.1.2"
[dev-dependencies.assert_cmd] [dev-dependencies.assert_cmd]
-version = ">= 2, <= 2.0.5" -version = ">= 2, <= 2.0.5"
+version = "2" +version = "2"

@ -1,10 +1,10 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
%bcond_without check %bcond_without check
%global crate difftastic %global crate difftastic
Name: rust-difftastic Name: rust-difftastic
Version: 0.51.1 Version: 0.53.1
Release: %autorelease Release: %autorelease
Summary: Structural diff that understands syntax Summary: Structural diff that understands syntax
@ -13,10 +13,17 @@ URL: https://crates.io/crates/difftastic
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * unpin libmimalloc-sys # * unpin libmimalloc-sys
# * remove upper bound on assert_cmd, predicates, and regex # * remove upper bound on:
# * aho-corasick
# * assert_cmd
# * ignore
# * is-terminal
# * memchr
# * predicates
# * regex
Patch: difftastic-fix-metadata.diff Patch: difftastic-fix-metadata.diff
BuildRequires: rust-packaging >= 23 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
A structural diff that understands syntax.} A structural diff that understands syntax.}
@ -25,16 +32,16 @@ A structural diff that understands syntax.}
%package -n %{crate} %package -n %{crate}
Summary: %{summary} Summary: %{summary}
# from %%cargo_license_summary
# (MIT OR Apache-2.0) AND Unicode-DFS-2016 # (MIT OR Apache-2.0) AND Unicode-DFS-2016
# Apache-2.0 OR BSL-1.0 # Apache-2.0 OR BSL-1.0
# Apache-2.0 OR MIT # Apache-2.0 OR MIT
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT # Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
# MIT # MIT
# MIT AND Unicode-DFS-2016 AND BSD-2-Clause AND BSD-3-Clause AND LicenseRef-Fedora-Public-Domain
# MIT OR Apache-2.0 # MIT OR Apache-2.0
# Unlicense OR MIT # Unlicense OR MIT
# Zlib # Zlib
License: (MIT OR Apache-2.0) AND Unicode-DFS-2016 AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND MIT AND (Unlicense OR MIT) AND Zlib License: ((MIT OR Apache-2.0) AND Unicode-DFS-2016) AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND MIT AND (MIT AND Unicode-DFS-2016 AND BSD-2-Clause AND BSD-3-Clause AND LicenseRef-Fedora-Public-Domain) AND (Unlicense OR MIT) AND Zlib
# LICENSE.dependencies contains a full license breakdown # LICENSE.dependencies contains a full license breakdown
%description -n %{crate} %{_description} %description -n %{crate} %{_description}
@ -46,7 +53,7 @@ License: (MIT OR Apache-2.0) AND Unicode-DFS-2016 AND (Apache-2.0 OR BSL-
%{_bindir}/difft %{_bindir}/difft
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -1 +1 @@
SHA512 (difftastic-0.51.1.crate) = a853afca0f21481f712aa4ff3f356f7d85e524bfd4485029bae849de150d1a9b18bd769b44c56fb38ca2d694a8b53b4e16bf44af7628c505bee0d8463aac295b SHA512 (difftastic-0.53.1.crate) = 9c1b786e77b53508c4802cd1c50330eacf1495b91be6c2a6344305e99d9f1ede5e7d9bc95d036e4c8e665639fc8f48d89f4bc457161fecb5a85140aded82151c

Loading…
Cancel
Save