commit
9fe6a4c9fc
@ -0,0 +1,24 @@
|
||||
From f96d339a2ad8535de6cb193d49e75bc10f90a8db Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Robert-Andr=C3=A9=20Mauchin?=
|
||||
<30413512+eclipseo@users.noreply.github.com>
|
||||
Date: Sat, 14 Sep 2019 22:35:43 +0200
|
||||
Subject: [PATCH] Use ..= for an inclusive range instead of deprecated ...
|
||||
|
||||
https://github.com/rust-lang/rust/issues/51043
|
||||
---
|
||||
src/display.rs | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/display.rs b/src/display.rs
|
||||
index 826cb10..2563974 100644
|
||||
--- a/src/display.rs
|
||||
+++ b/src/display.rs
|
||||
@@ -68,7 +68,7 @@ mod tests {
|
||||
// 9 => print!("{}", *b as char), // TAB
|
||||
b'\n' => print!("\\n"),
|
||||
b'\r' => print!("\\r"),
|
||||
- 32...126 => print!("{}", *b as char), // visible ASCII
|
||||
+ 32..=126 => print!("{}", *b as char), // visible ASCII
|
||||
_ => print!(r"\x{:0>2x}", b),
|
||||
|
||||
}
|
Binary file not shown.
@ -0,0 +1,22 @@
|
||||
--- difference-2.0.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ difference-2.0.0/Cargo.toml 2019-09-13T18:26:35.178734+00:00
|
||||
@@ -25,17 +25,13 @@
|
||||
[[bin]]
|
||||
name = "difference"
|
||||
doc = false
|
||||
-[dependencies.getopts]
|
||||
-version = "0.2"
|
||||
-optional = true
|
||||
[dev-dependencies.quickcheck]
|
||||
-version = "0.4"
|
||||
+version = "0.9"
|
||||
|
||||
[dev-dependencies.term]
|
||||
-version = "0.2.7"
|
||||
+version = "0.6"
|
||||
|
||||
[features]
|
||||
-bin = ["getopts"]
|
||||
default = []
|
||||
[badges.appveyor]
|
||||
repository = "johannhof/difference.rs"
|
@ -0,0 +1,145 @@
|
||||
# Generated by rust2rpm 10
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
# Binary is pretty useless
|
||||
%global __cargo_is_bin() false
|
||||
|
||||
%global crate difference
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 2.0.0
|
||||
Release: 19%{?dist}
|
||||
Summary: Rust text diffing and assertion library
|
||||
|
||||
# Upstream license specification: MIT
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/difference
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * Bump term to 0.6, https://github.com/johannhof/difference.rs/pull/42
|
||||
# * Bump quickcheck to 0.9, https://github.com/johannhof/difference.rs/pull/38
|
||||
# * Remove bin feature, it is useless
|
||||
Patch0: difference-fix-metadata.diff
|
||||
# Use ..= for an inclusive range instead of deprecated ...
|
||||
# https://github.com/johannhof/difference.rs/pull/41
|
||||
Patch1: https://patch-diff.githubusercontent.com/raw/johannhof/difference.rs/pull/41.patch#/0001-Fix-inclusive-range.patch
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Rust text diffing and assertion library.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 2.0.0-19
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-15
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Dec 14 03:15:34 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 2.0.0-12
|
||||
- Bump term to 0.6
|
||||
|
||||
* Fri Sep 13 20:26:35 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 2.0.0-11
|
||||
- Bump quickcheck to 0.9
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Jun 21 21:38:44 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.0-9
|
||||
- Regenerate
|
||||
|
||||
* Sun Feb 17 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.0-8
|
||||
- Tests are run in infrastructure
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Nov 13 2018 Josh Stone <jistone@redhat.com> - 2.0.0-6
|
||||
- Adapt to new packaging
|
||||
|
||||
* Mon Sep 10 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.0-5
|
||||
- Bump quickcheck to 0.7
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu May 10 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.0-3
|
||||
- Bump term to 0.5
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Jan 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.0-1
|
||||
- Initial package
|
Loading…
Reference in new issue