Bump quickcheck to 0.9

Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
epel9
Robert-André Mauchin 6 years ago
parent 29849d90dc
commit 0e0f92d0fd

@ -0,0 +1,24 @@
From f96d339a2ad8535de6cb193d49e75bc10f90a8db Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Robert-Andr=C3=A9=20Mauchin?=
<30413512+eclipseo@users.noreply.github.com>
Date: Sat, 14 Sep 2019 22:35:43 +0200
Subject: [PATCH] Use ..= for an inclusive range instead of deprecated ...
https://github.com/rust-lang/rust/issues/51043
---
src/display.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/display.rs b/src/display.rs
index 826cb10..2563974 100644
--- a/src/display.rs
+++ b/src/display.rs
@@ -68,7 +68,7 @@ mod tests {
// 9 => print!("{}", *b as char), // TAB
b'\n' => print!("\\n"),
b'\r' => print!("\\r"),
- 32...126 => print!("{}", *b as char), // visible ASCII
+ 32..=126 => print!("{}", *b as char), // visible ASCII
_ => print!(r"\x{:0>2x}", b),
}

@ -1,5 +1,5 @@
--- difference-2.0.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ difference-2.0.0/Cargo.toml 2019-06-21T19:38:43.050593+00:00
+++ difference-2.0.0/Cargo.toml 2019-09-13T18:26:35.178734+00:00
@@ -25,17 +25,13 @@
[[bin]]
name = "difference"
@ -9,7 +9,7 @@
-optional = true
[dev-dependencies.quickcheck]
-version = "0.4"
+version = "0.8"
+version = "0.9"
[dev-dependencies.term]
-version = "0.2.7"

@ -9,7 +9,7 @@
Name: rust-%{crate}
Version: 2.0.0
Release: 10%{?dist}
Release: 11%{?dist}
Summary: Rust text diffing and assertion library
# Upstream license specification: MIT
@ -18,9 +18,12 @@ URL: https://crates.io/crates/difference
Source: %{crates_source}
# Initial patched metadata
# * Bump term to 0.5, https://github.com/johannhof/difference.rs/commit/01fb76830c72a716300b20c66866a226286e8670
# * Bump quickcheck to 0.7, https://github.com/johannhof/difference.rs/pull/38
# * Bump quickcheck to 0.9, https://github.com/johannhof/difference.rs/pull/38
# * Remove bin feature, it is useless
Patch0: difference-fix-metadata.diff
# Use ..= for an inclusive range instead of deprecated ...
# https://github.com/johannhof/difference.rs/pull/41
Patch1: https://patch-diff.githubusercontent.com/raw/johannhof/difference.rs/pull/41.patch#/0001-Fix-inclusive-range.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -80,6 +83,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Fri Sep 13 20:26:35 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 2.0.0-11
- Bump quickcheck to 0.9
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

Loading…
Cancel
Save