parent
4b89ccaa80
commit
d9b469cc36
@ -0,0 +1 @@
|
|||||||
|
/derive_builder_core-0.4.1.crate
|
@ -0,0 +1,11 @@
|
|||||||
|
--- derive_builder_core-0.4.1/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ derive_builder_core-0.4.1/Cargo.toml 2019-03-13T17:06:09.719840+01:00
|
||||||
|
@@ -36,7 +36,7 @@
|
||||||
|
version = "0.15"
|
||||||
|
features = ["full", "extra-traits"]
|
||||||
|
[dev-dependencies.pretty_assertions]
|
||||||
|
-version = "0.5"
|
||||||
|
+version = "0.6"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
logging = ["log"]
|
@ -0,0 +1,105 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate derive_builder_core
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.4.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Internal helper library for the derive_builder crate
|
||||||
|
|
||||||
|
# Upstream license specification: MIT/Apache-2.0
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/derive_builder_core
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Update pretty_assertions to 0.6, https://github.com/colin-kiegel/rust-derive-builder/pull/143
|
||||||
|
Patch0: derive_builder_core-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
BuildRequires: (crate(darling/default) >= 0.8.5 with crate(darling/default) < 0.9.0)
|
||||||
|
BuildRequires: (crate(proc-macro2/default) >= 0.4.0 with crate(proc-macro2/default) < 0.5.0)
|
||||||
|
BuildRequires: (crate(quote/default) >= 0.6.0 with crate(quote/default) < 0.7.0)
|
||||||
|
BuildRequires: (crate(syn/default) >= 0.15.0 with crate(syn/default) < 0.16.0)
|
||||||
|
BuildRequires: (crate(syn/extra-traits) >= 0.15.0 with crate(syn/extra-traits) < 0.16.0)
|
||||||
|
BuildRequires: (crate(syn/full) >= 0.15.0 with crate(syn/full) < 0.16.0)
|
||||||
|
%if %{with check}
|
||||||
|
BuildRequires: (crate(pretty_assertions/default) >= 0.6.0 with crate(pretty_assertions/default) < 0.7.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%global _description \
|
||||||
|
Internal helper library for the derive_builder crate.
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc README.md CHANGELOG.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+log-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+log-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "log" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+log-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+logging-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+logging-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "logging" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+logging-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Mar 13 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.1-1
|
||||||
|
- Initial package
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (derive_builder_core-0.4.1.crate) = abb287b29f4c47741c7f8cccc7d96d23312f2880011a428613562de387326c76b15aef7e9449de3fa5c8f471330fe42639b9f06f7b9ceb16256fd97df764db80
|
@ -0,0 +1 @@
|
|||||||
|
1
|
@ -0,0 +1,5 @@
|
|||||||
|
---
|
||||||
|
standard-inventory-qcow2:
|
||||||
|
qemu:
|
||||||
|
# `cargo test` usually eats more than 1G.
|
||||||
|
m: 4G
|
@ -0,0 +1,13 @@
|
|||||||
|
---
|
||||||
|
- hosts: localhost
|
||||||
|
roles:
|
||||||
|
- role: standard-test-basic
|
||||||
|
tags:
|
||||||
|
- classic
|
||||||
|
repositories:
|
||||||
|
- repo: "https://src.fedoraproject.org/tests/rust.git"
|
||||||
|
dest: rust
|
||||||
|
tests:
|
||||||
|
- rust/cargo-test
|
||||||
|
environment:
|
||||||
|
pkg: rust-derive_builder_core
|
Loading…
Reference in new issue