commit
a82092ba0c
Binary file not shown.
@ -0,0 +1,11 @@
|
||||
--- derive_builder-0.9.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ derive_builder-0.9.0/Cargo.toml 2021-05-01T13:21:33.754267+00:00
|
||||
@@ -30,7 +30,7 @@
|
||||
optional = true
|
||||
|
||||
[dependencies.darling]
|
||||
-version = "0.10.2"
|
||||
+version = "0.12"
|
||||
|
||||
[dependencies.derive_builder_core]
|
||||
version = "=0.9.0"
|
@ -0,0 +1,152 @@
|
||||
# Generated by rust2rpm 17
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate derive_builder
|
||||
|
||||
Name: rust-%{crate}0.9
|
||||
Version: 0.9.0
|
||||
Release: 4%{?dist}
|
||||
Summary: Rust macro to automatically implement the builder pattern for arbitrary structs
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/derive_builder
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * bump to darling 0.12 (already upstream for 0.10)
|
||||
Patch0: derive_builder-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Rust macro to automatically implement the builder pattern for arbitrary
|
||||
structs.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.md CHANGELOG.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+env_logger-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+env_logger-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "env_logger" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+env_logger-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+log-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+log-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "log" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+log-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+logging-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+logging-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "logging" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+logging-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+skeptic-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+skeptic-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "skeptic" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+skeptic-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+skeptic_tests-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+skeptic_tests-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "skeptic_tests" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+skeptic_tests-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.9.0-4
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.0-2
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Sat May 01 2021 Fabio Valentini <decathorpe@gmail.com> - 0.9.0-1
|
||||
- Initial compat package for derive_builder 0.9
|
Loading…
Reference in new issue