commit
c3a5adefa1
Binary file not shown.
@ -0,0 +1,11 @@
|
|||||||
|
--- deflate-0.8.6/Cargo.toml 2020-07-06T16:16:04+00:00
|
||||||
|
+++ deflate-0.8.6/Cargo.toml 2022-08-09T09:18:35.554574+00:00
|
||||||
|
@@ -33,7 +33,7 @@
|
||||||
|
version = "1"
|
||||||
|
|
||||||
|
[dependencies.gzip-header]
|
||||||
|
-version = "0.3"
|
||||||
|
+version = "1"
|
||||||
|
optional = true
|
||||||
|
[dev-dependencies.miniz_oxide]
|
||||||
|
version = "0.3.6"
|
@ -0,0 +1,132 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.0)
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 3;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 22
|
||||||
|
# * files that are required by tests are not included in published crates
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate deflate
|
||||||
|
|
||||||
|
Name: rust-deflate0.8
|
||||||
|
Version: 0.8.6
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: DEFLATE, zlib and gzip encoder written in rust
|
||||||
|
|
||||||
|
# Upstream license specification: MIT/Apache-2.0
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/deflate
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * bump gzip-header from 0.3 to 1
|
||||||
|
Patch: deflate-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
DEFLATE, zlib and gzip encoder written in rust.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%doc %{crate_instdir}/changelog.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+benchmarks-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+benchmarks-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "benchmarks" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+benchmarks-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+gzip-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+gzip-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "gzip" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+gzip-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+gzip-header-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+gzip-header-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "gzip-header" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+gzip-header-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.8.6-3
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Tue Aug 09 2022 Fabio Valentini <decathorpe@gmail.com> 0.8.6-3
|
||||||
|
- Bump gzip-header from 0.3 to 1
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.8.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 02 2022 Fabio Valentini <decathorpe@gmail.com> 0.8.6-1
|
||||||
|
- Initial import (deflate 0.8 compat package)
|
Loading…
Reference in new issue