Update to 0.5.0

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 5 years ago
parent 776bce9389
commit b8a530ad6a
No known key found for this signature in database
GPG Key ID: 115D5AB89C5C1E1E

1
.gitignore vendored

@ -1 +1,2 @@
/datetime-0.4.7.crate /datetime-0.4.7.crate
/datetime-0.5.0.crate

@ -1,26 +0,0 @@
From 2ce3535d44ac97d45d19a5066d96e3926bdc52df Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Tue, 21 Nov 2017 07:13:56 +0100
Subject: [PATCH] drop regex from dependency set
It is effectively not used.
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
tests/parsing.rs | 1 -
1 file changed, 1 deletion(-)
diff --git a/tests/parsing.rs b/tests/parsing.rs
index 04a007b..22e5254 100644
--- a/tests/parsing.rs
+++ b/tests/parsing.rs
@@ -1,6 +1,5 @@
extern crate datetime;
use datetime::{LocalDateTime, Weekday, Month, LocalDate};
-extern crate regex;
extern crate rustc_serialize;
use rustc_serialize::json::Json;
--
2.15.0

@ -1,26 +1,11 @@
--- datetime-0.4.7/Cargo.toml 1970-01-01T00:00:00+00:00 --- datetime-0.5.0/Cargo.toml 2020-04-07T23:43:49+00:00
+++ datetime-0.4.7/Cargo.toml 2019-07-14T17:18:07.401572+00:00 +++ datetime-0.5.0/Cargo.toml 2020-05-17T07:45:21.031321+00:00
@@ -29,22 +29,12 @@ @@ -39,8 +39,3 @@
version = "0.2" version = "0.1"
[dependencies.iso8601]
-version = "0.1.0"
+version = "0.3"
[dependencies.num-traits]
version = "0.1.35"
[dependencies.libc]
version = "0.2"
-[dev-dependencies.regex]
-version = "0.1"
-
[dev-dependencies.rustc-serialize] [dev-dependencies.rustc-serialize]
version = "0.3" version = "0.3"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.2.8"
-
-[target."cfg(windows)".dependencies.kernel32-sys]
-version = "0.2.2"
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall] -[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
-version = "0.1.29" -version = "0.1.29"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.8"
-features = ["sysinfoapi", "minwindef"]

@ -1,27 +1,22 @@
# Generated by rust2rpm 10 # Generated by rust2rpm 13
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate datetime %global crate datetime
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.4.7 Version: 0.5.0
Release: 8%{?dist} Release: 1%{?dist}
Summary: Library for date and time formatting and arithmetic Summary: Library for date and time formatting and arithmetic
# Upstream license specification: MIT # Upstream license specification: MIT
# https://github.com/rust-datetime/datetime/issues/20 # https://github.com/rust-datetime/datetime/pull/29
License: MIT License: MIT
URL: https://crates.io/crates/datetime URL: https://crates.io/crates/datetime
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * No windows # * No windows/redox
# * No redox
# * Drop regex dependency, https://github.com/rust-datetime/datetime/pull/19
# * Bump iso8601 to 0.3, https://github.com/rust-datetime/datetime/pull/24
Patch0: datetime-fix-metadata.diff Patch0: datetime-fix-metadata.diff
# Really drop regex dependency
Patch1: 0001-drop-regex-from-dependency-set.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
@ -46,8 +41,7 @@ which use "%{crate}" crate.
%files devel %files devel
%doc README.md %doc README.md
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%exclude %{cargo_registry}/%{crate}-%{version}/tests/generate_tests.rb
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -59,7 +53,7 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate. which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
@ -80,6 +74,9 @@ which use "default" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sun May 17 09:45:21 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.5.0-1
- Update to 0.5.0
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.7-8 * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.7-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (datetime-0.4.7.crate) = c7b0503cae21628f64ba8740ffdf5798a7289ab7f6bb31fa02410bf36d7c5a0ace156ccbcb51fe57d7918e4885e608652af859b1e137a06b1a3b2d4a9a46bcc8 SHA512 (datetime-0.5.0.crate) = 64c67dce34613b90a0e5a880a587627055632cfe521b171c74b619c91bf3405fc938c708b280c7eb595f1adab4542ac83bfbc3344b66b7f45a6180b26baf66a3

Loading…
Cancel
Save