parent
32521a661a
commit
ae4130af57
@ -0,0 +1 @@
|
|||||||
|
/datetime-0.4.7.crate
|
@ -0,0 +1,26 @@
|
|||||||
|
From 2ce3535d44ac97d45d19a5066d96e3926bdc52df Mon Sep 17 00:00:00 2001
|
||||||
|
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||||
|
Date: Tue, 21 Nov 2017 07:13:56 +0100
|
||||||
|
Subject: [PATCH] drop regex from dependency set
|
||||||
|
|
||||||
|
It is effectively not used.
|
||||||
|
|
||||||
|
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||||
|
---
|
||||||
|
tests/parsing.rs | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/tests/parsing.rs b/tests/parsing.rs
|
||||||
|
index 04a007b..22e5254 100644
|
||||||
|
--- a/tests/parsing.rs
|
||||||
|
+++ b/tests/parsing.rs
|
||||||
|
@@ -1,6 +1,5 @@
|
||||||
|
extern crate datetime;
|
||||||
|
use datetime::{LocalDateTime, Weekday, Month, LocalDate};
|
||||||
|
-extern crate regex;
|
||||||
|
|
||||||
|
extern crate rustc_serialize;
|
||||||
|
use rustc_serialize::json::Json;
|
||||||
|
--
|
||||||
|
2.15.0
|
||||||
|
|
@ -0,0 +1,26 @@
|
|||||||
|
--- datetime-0.4.7/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ datetime-0.4.7/Cargo.toml 2017-11-21T07:27:20.696471+01:00
|
||||||
|
@@ -29,22 +29,13 @@
|
||||||
|
version = "0.2"
|
||||||
|
|
||||||
|
[dependencies.iso8601]
|
||||||
|
-version = "0.1.0"
|
||||||
|
+version = "0.2"
|
||||||
|
|
||||||
|
[dependencies.num-traits]
|
||||||
|
version = "0.1.35"
|
||||||
|
|
||||||
|
[dependencies.libc]
|
||||||
|
version = "0.2"
|
||||||
|
-[dev-dependencies.regex]
|
||||||
|
-version = "0.1"
|
||||||
|
|
||||||
|
[dev-dependencies.rustc-serialize]
|
||||||
|
version = "0.3"
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.2.8"
|
||||||
|
-
|
||||||
|
-[target."cfg(windows)".dependencies.kernel32-sys]
|
||||||
|
-version = "0.2.2"
|
||||||
|
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
|
||||||
|
-version = "0.1.29"
|
@ -0,0 +1,74 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate datetime
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.4.7
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Library for date and time formatting and arithmetic
|
||||||
|
|
||||||
|
# https://github.com/rust-datetime/datetime/issues/20
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/datetime
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * No windows
|
||||||
|
# * No redox
|
||||||
|
# * Drop regex dependency, https://github.com/rust-datetime/datetime/pull/19
|
||||||
|
# * Bump iso8601 to 0.2, https://github.com/rust-datetime/datetime/pull/21
|
||||||
|
Patch0: datetime-0.4.7-fix-metadata.diff
|
||||||
|
# Really drop regex dependency
|
||||||
|
Patch1: 0001-drop-regex-from-dependency-set.patch
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(iso8601) >= 0.2.0 with crate(iso8601) < 0.3.0)
|
||||||
|
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
|
||||||
|
BuildRequires: (crate(locale) >= 0.2.0 with crate(locale) < 0.3.0)
|
||||||
|
BuildRequires: (crate(num-traits) >= 0.1.35 with crate(num-traits) < 0.2.0)
|
||||||
|
BuildRequires: (crate(pad) >= 0.1.0 with crate(pad) < 0.2.0)
|
||||||
|
%if %{with check}
|
||||||
|
# [dev-dependencies]
|
||||||
|
BuildRequires: (crate(rustc-serialize) >= 0.3.0 with crate(rustc-serialize) < 0.4.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Library for date and time formatting and arithmetic.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
%exclude %{cargo_registry}/%{crate}-%{version}/tests/generate_tests.rb
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Nov 21 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.7-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue