Update to version 5.3.4; Fixes RHBZ#2031537

epel9
Fabio Valentini 3 years ago
parent c8825fc072
commit eab08fad17
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -8,3 +8,4 @@
/dashmap-3.11.7.crate /dashmap-3.11.7.crate
/dashmap-3.11.10.crate /dashmap-3.11.10.crate
/dashmap-4.0.2.crate /dashmap-4.0.2.crate
/dashmap-5.3.4.crate

@ -1,18 +0,0 @@
--- dashmap-3.11.10/Cargo.toml 2020-08-04T17:52:42+00:00
+++ dashmap-3.11.10/Cargo.toml 2020-09-28T22:40:22.903103+00:00
@@ -26,13 +26,13 @@
[package.metadata.docs.rs]
features = ["raw-api", "serde"]
[dependencies.ahash]
-version = "0.3.8"
+version = "0.4.4"
[dependencies.cfg-if]
version = "0.1.10"
[dependencies.hashbrown]
-version = "0.8.0"
+version = "0.9.0"
optional = true
[dependencies.num_cpus]

@ -1,25 +1,21 @@
# Generated by rust2rpm 17 # Generated by rust2rpm 22
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate dashmap %global crate dashmap
Name: rust-%{crate} Name: rust-dashmap
Version: 4.0.2 Version: 5.3.4
Release: %autorelease Release: %autorelease
Summary: Blazing fast concurrent HashMap for Rust Summary: Blazing fast concurrent HashMap for Rust
# Upstream license specification: MIT
License: MIT License: MIT
URL: https://crates.io/crates/dashmap URL: https://crates.io/crates/dashmap
Source: %{crates_source} Source: %{crates_source}
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Blazing fast concurrent HashMap for Rust.} Blazing fast concurrent HashMap for Rust.}
@ -32,13 +28,13 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE %license %{crate_instdir}/LICENSE
%doc README.md %doc %{crate_instdir}/README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -46,11 +42,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+raw-api-devel %package -n %{name}+raw-api-devel
Summary: %{summary} Summary: %{summary}
@ -58,11 +54,11 @@ BuildArch: noarch
%description -n %{name}+raw-api-devel %{_description} %description -n %{name}+raw-api-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "raw-api" feature of "%{crate}" crate. use the "raw-api" feature of the "%{crate}" crate.
%files -n %{name}+raw-api-devel %files -n %{name}+raw-api-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rayon-devel %package -n %{name}+rayon-devel
Summary: %{summary} Summary: %{summary}
@ -70,11 +66,11 @@ BuildArch: noarch
%description -n %{name}+rayon-devel %{_description} %description -n %{name}+rayon-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "rayon" feature of "%{crate}" crate. use the "rayon" feature of the "%{crate}" crate.
%files -n %{name}+rayon-devel %files -n %{name}+rayon-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
@ -82,11 +78,11 @@ BuildArch: noarch
%description -n %{name}+serde-devel %{_description} %description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "serde" feature of "%{crate}" crate. use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (dashmap-4.0.2.crate) = 1658183be619b781c5d9e33a2c709805053ab81187145517eb4bd22e12acb42426fef841a91618e889f4e7da792b88437bbf26e3899144222562c54575107d0e SHA512 (dashmap-5.3.4.crate) = 95310bc2b9e4ab46acc056ed0be8e75bb6e27e6bdb2bf2e0917482cdc86e64e5fb9159307016895f25282771fe3a367731d0e2c68c6aa5435154945cda52b6df

Loading…
Cancel
Save