parent
82d214d640
commit
b1efb5b758
@ -0,0 +1 @@
|
||||
/dary_heap-0.3.6.crate
|
@ -0,0 +1,13 @@
|
||||
--- dary_heap-0.3.6/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ dary_heap-0.3.6/Cargo.toml 2024-04-27T23:24:00.240285+00:00
|
||||
@@ -50,10 +50,6 @@
|
||||
optional = true
|
||||
default-features = false
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.4"
|
||||
-default-features = false
|
||||
-
|
||||
[dev-dependencies.rand]
|
||||
version = "0.8"
|
||||
|
@ -0,0 +1,97 @@
|
||||
# Generated by rust2rpm 26
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate dary_heap
|
||||
|
||||
Name: rust-dary_heap
|
||||
Version: 0.3.6
|
||||
Release: %autorelease
|
||||
Summary: D-ary heap
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/dary_heap
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop criterion dependency
|
||||
Patch: dary_heap-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
A d-ary heap.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+extra-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+extra-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "extra" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+extra-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,5 @@
|
||||
[features]
|
||||
hide = [
|
||||
"unstable",
|
||||
"unstable_nightly",
|
||||
]
|
Loading…
Reference in new issue