commit
14f337dc91
Binary file not shown.
@ -0,0 +1,14 @@
|
|||||||
|
--- darling-0.14.4/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ darling-0.14.4/Cargo.toml 2023-08-01T16:39:39.217634+00:00
|
||||||
|
@@ -48,11 +48,5 @@
|
||||||
|
diagnostics = ["darling_core/diagnostics"]
|
||||||
|
suggestions = ["darling_core/suggestions"]
|
||||||
|
|
||||||
|
-[target."cfg(compiletests)".dev-dependencies.rustversion]
|
||||||
|
-version = "1.0.9"
|
||||||
|
-
|
||||||
|
-[target."cfg(compiletests)".dev-dependencies.trybuild]
|
||||||
|
-version = "1.0.38"
|
||||||
|
-
|
||||||
|
[badges.maintenance]
|
||||||
|
status = "actively-developed"
|
@ -0,0 +1,110 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate darling
|
||||||
|
|
||||||
|
Name: rust-darling0.14
|
||||||
|
Version: 0.14.4
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Parse attributes into structs for custom derive implementations
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/darling
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip foreign dependencies
|
||||||
|
Patch: darling-fix-metadata-auto.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A proc-macro library for reading attributes into structs when
|
||||||
|
implementing custom derives.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+diagnostics-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+diagnostics-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "diagnostics" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+diagnostics-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+suggestions-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+suggestions-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "suggestions" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+suggestions-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.14.4-1
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Tue Aug 01 2023 Fabio Valentini <decathorpe@gmail.com> - 0.14.4-1
|
||||||
|
- Initial import (darling 0.14 compat package)
|
Loading…
Reference in new issue