Update to version 1.0.64; Fixes RHBZ#2048315

epel10
Fabio Valentini 3 years ago
parent 45678eba81
commit a740dae815
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -5,3 +5,4 @@
/cxxbridge-macro-1.0.60.crate
/cxxbridge-macro-1.0.62.crate
/cxxbridge-macro-1.0.63.crate
/cxxbridge-macro-1.0.64.crate

@ -1,28 +0,0 @@
From cf5bbe629ee54649e5ccb195bfd10e3c3b03ae53 Mon Sep 17 00:00:00 2001
From: David Tolnay <dtolnay@gmail.com>
Date: Tue, 18 Jan 2022 17:21:08 -0800
Subject: [PATCH] Fix variants_from_header build
---
macro/src/load.rs | 2 ++
1 file changed, 2 insertions(+)
diff --git a/macro/src/load.rs b/macro/src/load.rs
index d769ebf6..baf88413 100644
--- a/macro/src/load.rs
+++ b/macro/src/load.rs
@@ -1,5 +1,6 @@
use crate::clang::{Clang, Node};
use crate::syntax::attrs::OtherAttrs;
+use crate::syntax::cfg::CfgExpr;
use crate::syntax::namespace::Namespace;
use crate::syntax::report::Errors;
use crate::syntax::{Api, Discriminant, Doc, Enum, EnumRepr, ForeignName, Pair, Variant};
@@ -207,6 +208,7 @@ fn traverse<'a>(
}
};
enm.variants.push(Variant {
+ cfg: CfgExpr::Unconditional,
doc: Doc::new(),
attrs: OtherAttrs::none(),
name: Pair {

@ -1,11 +1,12 @@
# Generated by rust2rpm 20
%bcond_without check
# * resolve dependency loop with cxx
%bcond_with check
%global debug_package %{nil}
%global crate cxxbridge-macro
Name: rust-%{crate}
Version: 1.0.63
Version: 1.0.64
Release: %autorelease
Summary: Implementation detail of the cxx crate
@ -14,10 +15,6 @@ License: MIT or ASL 2.0
URL: https://crates.io/crates/cxxbridge-macro
Source: %{crates_source}
# Backports: Remove on update
# https://github.com/dtolnay/cxx/commit/cf5bbe629ee54649e5ccb195bfd10e3c3b03ae53.patch
Patch: fix-variants-from-headers-build.patch
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
@ -64,16 +61,28 @@ use the "clang-ast" feature of the "%{crate}" crate.
%files -n %{name}+clang-ast-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+experimental-devel
%package -n %{name}+experimental-async-fn-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+experimental-async-fn-devel %{_description}
This package contains library source intended for building other packages which
use the "experimental-async-fn" feature of the "%{crate}" crate.
%files -n %{name}+experimental-async-fn-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+experimental-enum-variants-from-header-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+experimental-devel %{_description}
%description -n %{name}+experimental-enum-variants-from-header-devel %{_description}
This package contains library source intended for building other packages which
use the "experimental" feature of the "%{crate}" crate.
use the "experimental-enum-variants-from-header" feature of the "%{crate}" crate.
%files -n %{name}+experimental-devel
%files -n %{name}+experimental-enum-variants-from-header-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+flate2-devel
@ -125,7 +134,7 @@ use the "serde_json" feature of the "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p2
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires

@ -1 +1 @@
SHA512 (cxxbridge-macro-1.0.63.crate) = ce804528bc33e783da9daf7a6d48efd8a5ae3f9ba08a1b3c16e6b6b4f8c6b979def354755bbd5161dadb9ab0f971c9398516f9d52bd86c432a86f30f53330639
SHA512 (cxxbridge-macro-1.0.64.crate) = 464a69ee89b4c4a664a396e441848edb3d2c14da4ec0aa80240c1d7303932c26af701d5795579ada5b032e9b6811cb9d304cd5a94bfba29b2ad9fb682fd4c67f

Loading…
Cancel
Save