Update to 0.4.26

epel9
Josh Stone 5 years ago
parent 838739201e
commit f23b4fd48a

1
.gitignore vendored

@ -8,3 +8,4 @@
/curl-0.4.20.crate /curl-0.4.20.crate
/curl-0.4.22.crate /curl-0.4.22.crate
/curl-0.4.25.crate /curl-0.4.25.crate
/curl-0.4.26.crate

@ -1,25 +1,27 @@
--- curl-0.4.25/Cargo.toml 1970-01-01T00:00:00+00:00 --- curl-0.4.26/Cargo.toml 2020-02-28T16:20:29+00:00
+++ curl-0.4.25/Cargo.toml 2019-11-23T00:18:29.474934+00:00 +++ curl-0.4.26/Cargo.toml 2020-03-02T22:10:08.579916+00:00
@@ -42,12 +42,8 @@ @@ -42,14 +42,10 @@
[features] [features]
default = ["ssl"] default = ["ssl"]
-force-system-lib-on-osx = ["curl-sys/force-system-lib-on-osx"] -force-system-lib-on-osx = ["curl-sys/force-system-lib-on-osx"]
http2 = ["curl-sys/http2"] http2 = ["curl-sys/http2"]
-mesalink = ["curl-sys/mesalink"] -mesalink = ["curl-sys/mesalink"]
protocol-ftp = ["curl-sys/protocol-ftp"]
spnego = ["curl-sys/spnego"]
ssl = ["openssl-sys", "openssl-probe", "curl-sys/ssl"] ssl = ["openssl-sys", "openssl-probe", "curl-sys/ssl"]
-static-curl = ["curl-sys/static-curl"] -static-curl = ["curl-sys/static-curl"]
-static-ssl = ["curl-sys/static-ssl"] -static-ssl = ["curl-sys/static-ssl"]
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe] [target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
version = "0.1.2" version = "0.1.2"
optional = true optional = true
@@ -55,12 +51,7 @@ @@ -57,12 +53,6 @@
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys] [target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
version = "0.9.43" version = "0.9.43"
optional = true optional = true
-[target."cfg(target_env = \"msvc\")".dependencies.schannel] -[target."cfg(target_env = \"msvc\")".dependencies.schannel]
-version = "0.1.13" -version = "0.1.13"
-
-[target."cfg(target_env = \"msvc\")".dependencies.winapi] -[target."cfg(target_env = \"msvc\")".dependencies.winapi]
-version = "0.3" -version = "0.3"
-features = ["libloaderapi", "wincrypt"] -features = ["libloaderapi", "wincrypt"]

@ -1,4 +1,4 @@
# Generated by rust2rpm 10 # Generated by rust2rpm 13
# Tests are run in infrastructure # Tests are run in infrastructure
%bcond_with check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
@ -6,8 +6,8 @@
%global crate curl %global crate curl
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.4.25 Version: 0.4.26
Release: 2%{?dist} Release: 1%{?dist}
Summary: Rust bindings to libcurl for making HTTP requests Summary: Rust bindings to libcurl for making HTTP requests
# Upstream license specification: MIT # Upstream license specification: MIT
@ -43,8 +43,8 @@ which use "%{crate}" crate.
%files devel %files devel
%license LICENSE %license LICENSE
%doc README.md %doc README.md
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%exclude %{cargo_registry}/%{crate}-%{version}/{appveyor.yml,ci} %exclude %{cargo_registry}/%{crate}-%{version_no_tilde}/{appveyor.yml,ci}
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -56,7 +56,7 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate. which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+http2-devel %package -n %{name}+http2-devel
Summary: %{summary} Summary: %{summary}
@ -68,7 +68,7 @@ This package contains library source intended for building other packages
which use "http2" feature of "%{crate}" crate. which use "http2" feature of "%{crate}" crate.
%files -n %{name}+http2-devel %files -n %{name}+http2-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+openssl-probe-devel %package -n %{name}+openssl-probe-devel
Summary: %{summary} Summary: %{summary}
@ -80,7 +80,7 @@ This package contains library source intended for building other packages
which use "openssl-probe" feature of "%{crate}" crate. which use "openssl-probe" feature of "%{crate}" crate.
%files -n %{name}+openssl-probe-devel %files -n %{name}+openssl-probe-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+openssl-sys-devel %package -n %{name}+openssl-sys-devel
Summary: %{summary} Summary: %{summary}
@ -92,7 +92,31 @@ This package contains library source intended for building other packages
which use "openssl-sys" feature of "%{crate}" crate. which use "openssl-sys" feature of "%{crate}" crate.
%files -n %{name}+openssl-sys-devel %files -n %{name}+openssl-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+protocol-ftp-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+protocol-ftp-devel %{_description}
This package contains library source intended for building other packages
which use "protocol-ftp" feature of "%{crate}" crate.
%files -n %{name}+protocol-ftp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+spnego-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+spnego-devel %{_description}
This package contains library source intended for building other packages
which use "spnego" feature of "%{crate}" crate.
%files -n %{name}+spnego-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+ssl-devel %package -n %{name}+ssl-devel
Summary: %{summary} Summary: %{summary}
@ -104,7 +128,7 @@ This package contains library source intended for building other packages
which use "ssl" feature of "%{crate}" crate. which use "ssl" feature of "%{crate}" crate.
%files -n %{name}+ssl-devel %files -n %{name}+ssl-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
@ -125,6 +149,9 @@ which use "ssl" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Mon Mar 02 2020 Josh Stone <jistone@redhat.com> - 0.4.26-1
- Update to 0.4.26
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.25-2 * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.25-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (curl-0.4.25.crate) = c42efa6bcb5989c4f3a91629d0a547448ccce7fc8556b802ed2bdd10941cae25bb1ad15cd914024f1fdb0d1799ac2345fdc649b985b86eb87074b2b80e7c80d3 SHA512 (curl-0.4.26.crate) = edf82bae7cd3c3dc40942073ebabca954c6a6ced08bc66d5b38aea10a7b7e284af3ccfb37b20462ef4b8eba9e6ff1de48e7df8f07e052711379b26418980f6ad

Loading…
Cancel
Save