remove feature with broken dependencies (curl-sys/mesalink)

epel9
Fabio Valentini 4 years ago
parent 3dc651906d
commit b9177c5947
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -0,0 +1,5 @@
[DEFAULT]
unwanted-features =
force-system-lib-on-osx
mesalink
zlib-ng-compat

@ -1,20 +1,12 @@
--- curl-0.4.33/Cargo.toml 2020-08-19T05:24:59+00:00 --- curl-0.4.33/Cargo.toml 2020-08-19T05:24:59+00:00
+++ curl-0.4.33/Cargo.toml 2020-08-20T00:16:59.306449+00:00 +++ curl-0.4.33/Cargo.toml 2020-12-02T13:41:08.205229+00:00
@@ -59,7 +59,6 @@ @@ -67,12 +67,7 @@
ssl = ["openssl-sys", "openssl-probe", "curl-sys/ssl"]
static-curl = ["curl-sys/static-curl"]
static-ssl = ["curl-sys/static-ssl"]
-zlib-ng-compat = ["curl-sys/zlib-ng-compat", "static-curl"]
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
version = "0.1.2"
optional = true
@@ -67,12 +66,6 @@
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys] [target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
version = "0.9.43" version = "0.9.43"
optional = true optional = true
-[target."cfg(target_env = \"msvc\")".dependencies.schannel] -[target."cfg(target_env = \"msvc\")".dependencies.schannel]
-version = "0.1.13" -version = "0.1.13"
-
-[target."cfg(target_env = \"msvc\")".dependencies.winapi] -[target."cfg(target_env = \"msvc\")".dependencies.winapi]
-version = "0.3" -version = "0.3"
-features = ["libloaderapi", "wincrypt"] -features = ["libloaderapi", "wincrypt"]

@ -1,4 +1,4 @@
# Generated by rust2rpm 13 # Generated by rust2rpm 16
# * Tests are too environment dependent # * Tests are too environment dependent
%bcond_with check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
@ -7,7 +7,7 @@
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.4.33 Version: 0.4.33
Release: 1%{?dist} Release: 2%{?dist}
Summary: Rust bindings to libcurl for making HTTP requests Summary: Rust bindings to libcurl for making HTTP requests
# Upstream license specification: MIT # Upstream license specification: MIT
@ -16,7 +16,6 @@ URL: https://crates.io/crates/curl
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * No windows/osx # * No windows/osx
# * No zlib-ng features
Patch0: curl-fix-metadata.diff Patch0: curl-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -44,6 +43,7 @@ which use "%{crate}" crate.
%license LICENSE %license LICENSE
%doc README.md %doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%exclude %{cargo_registry}/%{crate}-%{version_no_tilde}/{ci/,.github/}
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -57,18 +57,6 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+force-system-lib-on-osx-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+force-system-lib-on-osx-devel %{_description}
This package contains library source intended for building other packages
which use "force-system-lib-on-osx" feature of "%{crate}" crate.
%files -n %{name}+force-system-lib-on-osx-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+http2-devel %package -n %{name}+http2-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -81,18 +69,6 @@ which use "http2" feature of "%{crate}" crate.
%files -n %{name}+http2-devel %files -n %{name}+http2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+mesalink-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mesalink-devel %{_description}
This package contains library source intended for building other packages
which use "mesalink" feature of "%{crate}" crate.
%files -n %{name}+mesalink-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+openssl-probe-devel %package -n %{name}+openssl-probe-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -196,6 +172,9 @@ which use "static-ssl" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Wed Dec 02 2020 Fabio Valentini <decathorpe@gmail.com> - 0.4.33-2
- Remove feature with broken dependencies (curl-sys/mesalink).
* Thu Aug 20 2020 Josh Stone <jistone@redhat.com> - 0.4.33-1 * Thu Aug 20 2020 Josh Stone <jistone@redhat.com> - 0.4.33-1
- Update to 0.4.33 - Update to 0.4.33

Loading…
Cancel
Save