Drop unused features for statically linking cURL and OpenSSL

epel9 imports/e9/rust-curl-0.4.44-3.el9
Fabio Valentini 2 years ago
parent b3e18e1084
commit a2b4ccf51d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,3 +0,0 @@
# rust-curl
The rust-curl package

@ -0,0 +1,19 @@
--- curl-0.4.44/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-0.4.44/Cargo.toml 2023-03-02T13:43:53.758003+00:00
@@ -107,16 +107,6 @@
version = "0.9.43"
optional = true
-[target."cfg(target_env = \"msvc\")".dependencies.schannel]
-version = "0.1.13"
-
-[target."cfg(target_env = \"msvc\")".dependencies.winapi]
-version = "0.3"
-features = [
- "libloaderapi",
- "wincrypt",
-]
-
[badges.appveyor]
repository = "alexcrichton/curl-rust"

@ -1,16 +1,14 @@
--- curl-0.4.44/Cargo.toml 1970-01-01T00:00:01+00:00 --- curl-0.4.44/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-0.4.44/Cargo.toml 2022-07-22T10:26:15.295988+00:00 +++ curl-0.4.44/Cargo.toml 2023-03-02T13:44:31.215139+00:00
@@ -25,6 +25,9 @@ @@ -25,6 +25,7 @@
] ]
license = "MIT" license = "MIT"
repository = "https://github.com/alexcrichton/curl-rust" repository = "https://github.com/alexcrichton/curl-rust"
+exclude = [ +exclude = ["/ci/"]
+ "/ci/",
+]
[[example]] [[example]]
name = "https" name = "https"
@@ -52,10 +55,6 @@ @@ -52,10 +53,6 @@
name = "multi-dl" name = "multi-dl"
path = "examples/multi-dl.rs" path = "examples/multi-dl.rs"
required-features = ["ssl"] required-features = ["ssl"]
@ -21,20 +19,3 @@
[dependencies.curl-sys] [dependencies.curl-sys]
version = "0.4.56" version = "0.4.56"
@@ -107,16 +106,6 @@
version = "0.9.43"
optional = true
-[target."cfg(target_env = \"msvc\")".dependencies.schannel]
-version = "0.1.13"
-
-[target."cfg(target_env = \"msvc\")".dependencies.winapi]
-version = "0.3"
-features = [
- "libloaderapi",
- "wincrypt",
-]
-
[badges.appveyor]
repository = "alexcrichton/curl-rust"

@ -1,25 +1,23 @@
# Generated by rust2rpm 21 # Generated by rust2rpm 24
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate curl %global crate curl
Name: rust-%{crate} Name: rust-curl
Version: 0.4.44 Version: 0.4.44
Release: %autorelease Release: %autorelease
Summary: Rust bindings to libcurl for making HTTP requests Summary: Rust bindings to libcurl for making HTTP requests
# Upstream license specification: MIT
License: MIT License: MIT
URL: https://crates.io/crates/curl URL: https://crates.io/crates/curl
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Automatically generated patch to strip foreign dependencies
# * drop windows- and mac OS-specific dependencies Patch: curl-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop test binary that requires internet connectivity # * drop test binary that requires internet connectivity
# * exclude upstream CI files # * exclude upstream CI files
Patch0: curl-fix-metadata.diff Patch: curl-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21 BuildRequires: rust-packaging >= 21
@ -150,30 +148,6 @@ use the "ssl" feature of the "%{crate}" crate.
%files -n %{name}+ssl-devel %files -n %{name}+ssl-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+static-curl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+static-curl-devel %{_description}
This package contains library source intended for building other packages which
use the "static-curl" feature of the "%{crate}" crate.
%files -n %{name}+static-curl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+static-ssl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+static-ssl-devel %{_description}
This package contains library source intended for building other packages which
use the "static-ssl" feature of the "%{crate}" crate.
%files -n %{name}+static-ssl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+upkeep_7_62_0-devel %package -n %{name}+upkeep_7_62_0-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch

@ -3,4 +3,6 @@ unwanted-features =
force-system-lib-on-osx force-system-lib-on-osx
mesalink mesalink
rustls rustls
static-curl
static-ssl
zlib-ng-compat zlib-ng-compat
Loading…
Cancel
Save