Update to 0.4.19

Adapt to new packaging
epel9
Josh Stone 6 years ago
parent 4861cc1527
commit 8b6f9cb4a6

1
.gitignore vendored

@ -4,3 +4,4 @@
/curl-0.4.15.crate
/curl-0.4.17.crate
/curl-0.4.18.crate
/curl-0.4.19.crate

@ -1,9 +1,21 @@
--- curl-0.4.14/Cargo.toml 1969-12-31T16:00:00-08:00
+++ curl-0.4.14/Cargo.toml 2018-09-07T16:05:05.901118-07:00
@@ -38,13 +38,6 @@
--- curl-0.4.19/Cargo.toml 1969-12-31T16:00:00-08:00
+++ curl-0.4.19/Cargo.toml 2018-11-09T17:44:15.757331-08:00
@@ -42,11 +42,8 @@
[features]
default = ["ssl"]
-force-system-lib-on-osx = ["curl-sys/force-system-lib-on-osx"]
http2 = ["curl-sys/http2"]
ssl = ["openssl-sys", "openssl-probe", "curl-sys/ssl"]
-static-curl = ["curl-sys/static-curl"]
-static-ssl = ["curl-sys/static-ssl"]
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
version = "0.1.2"
optional = true
@@ -54,13 +51,6 @@
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
version = "0.9.33"
optional = true
-[target."cfg(target_env = \"msvc\")".dependencies.kernel32-sys]
-version = "0.2.2"
-

@ -6,7 +6,7 @@
%global crate curl
Name: rust-%{crate}
Version: 0.4.18
Version: 0.4.19
Release: 1%{?dist}
Summary: Rust bindings to libcurl for making HTTP requests
@ -15,35 +15,103 @@ URL: https://crates.io/crates/curl
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * No windows/osx
# * No static features
Patch0: curl-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(curl-sys) >= 0.4.9 with crate(curl-sys) < 0.5.0)
BuildRequires: (crate(libc) >= 0.2.42 with crate(libc) < 0.3.0)
BuildRequires: (crate(openssl-probe) >= 0.1.2 with crate(openssl-probe) < 0.2.0)
BuildRequires: (crate(openssl-sys) >= 0.9.33 with crate(openssl-sys) < 0.10.0)
BuildRequires: (crate(socket2) >= 0.3.7 with crate(socket2) < 0.4.0)
BuildRequires: (crate(curl-sys) >= 0.4.15 with crate(curl-sys) < 0.5.0)
BuildRequires: (crate(curl-sys/http2) >= 0.4.15 with crate(curl-sys/http2) < 0.5.0)
BuildRequires: (crate(curl-sys/ssl) >= 0.4.15 with crate(curl-sys/ssl) < 0.5.0)
BuildRequires: (crate(libc/default) >= 0.2.42 with crate(libc/default) < 0.3.0)
BuildRequires: (crate(openssl-probe/default) >= 0.1.2 with crate(openssl-probe/default) < 0.2.0)
BuildRequires: (crate(openssl-sys/default) >= 0.9.33 with crate(openssl-sys/default) < 0.10.0)
BuildRequires: (crate(socket2/default) >= 0.3.7 with crate(socket2/default) < 0.4.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(mio) >= 0.6.0 with crate(mio) < 0.7.0)
BuildRequires: (crate(mio-extras) >= 2.0.3 with crate(mio-extras) < 3.0.0)
BuildRequires: (crate(mio-extras/default) >= 2.0.3 with crate(mio-extras/default) < 3.0.0)
BuildRequires: (crate(mio/default) >= 0.6.0 with crate(mio/default) < 0.7.0)
%endif
%description
%{summary}.
%global _description \
Rust bindings to libcurl for making HTTP requests.
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
Rust bindings to libcurl for making HTTP requests.
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{appveyor.yml,ci}
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use %{crate} from crates.io.
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+http2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+http2-devel %{_description}
This package contains library source intended for building other packages
which use "http2" feature of "%{crate}" crate.
%files -n %{name}+http2-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+openssl-probe-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+openssl-probe-devel %{_description}
This package contains library source intended for building other packages
which use "openssl-probe" feature of "%{crate}" crate.
%files -n %{name}+openssl-probe-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+openssl-sys-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+openssl-sys-devel %{_description}
This package contains library source intended for building other packages
which use "openssl-sys" feature of "%{crate}" crate.
%files -n %{name}+openssl-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+ssl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ssl-devel %{_description}
This package contains library source intended for building other packages
which use "ssl" feature of "%{crate}" crate.
%files -n %{name}+ssl-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
@ -60,13 +128,11 @@ which use %{crate} from crates.io.
%cargo_test
%endif
%files devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{appveyor.yml,ci}
%changelog
* Sat Nov 10 2018 Josh Stone <jistone@redhat.com> - 0.4.19-1
- Update to 0.4.19
- Adapt to new packaging
* Mon Oct 01 2018 Josh Stone <jistone@redhat.com> - 0.4.18-1
- Update to 0.4.18

@ -1 +1 @@
SHA512 (curl-0.4.18.crate) = 3635589f497b365ff10885bc8fca67a532e2e5b106d82d67fea79f3b0433407aba54b75b20852cab5696cef61d11141c1e6db510904029db06ba64ed4f9f6643
SHA512 (curl-0.4.19.crate) = dbcd94b7695db392ed2ad6b3335c0a9bd3db29319cf301489d5f902f250917c64fe6cf51476f0f1873275ab6984df73c39b6b3be3a7f43faddfb692333b68588

Loading…
Cancel
Save