Restore static features

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 5 years ago
parent 3032c59ab3
commit 4f4cdb943d
No known key found for this signature in database
GPG Key ID: 115D5AB89C5C1E1E

@ -1,21 +1,6 @@
--- curl-0.4.26/Cargo.toml 2020-02-28T16:20:29+00:00 --- curl-0.4.29/Cargo.toml 2020-04-29T16:03:08+00:00
+++ curl-0.4.26/Cargo.toml 2020-03-02T22:10:08.579916+00:00 +++ curl-0.4.29/Cargo.toml 2020-05-17T14:15:02.163607+00:00
@@ -42,14 +42,10 @@ @@ -57,12 +57,6 @@
[features]
default = ["ssl"]
-force-system-lib-on-osx = ["curl-sys/force-system-lib-on-osx"]
http2 = ["curl-sys/http2"]
-mesalink = ["curl-sys/mesalink"]
protocol-ftp = ["curl-sys/protocol-ftp"]
spnego = ["curl-sys/spnego"]
ssl = ["openssl-sys", "openssl-probe", "curl-sys/ssl"]
-static-curl = ["curl-sys/static-curl"]
-static-ssl = ["curl-sys/static-ssl"]
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
version = "0.1.2"
optional = true
@@ -57,12 +53,6 @@
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys] [target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
version = "0.9.43" version = "0.9.43"
optional = true optional = true

@ -1,5 +1,5 @@
# Generated by rust2rpm 13 # Generated by rust2rpm 13
# Tests are run in infrastructure # * Tests are too environment dependent
%bcond_with check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
@ -7,7 +7,7 @@
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.4.29 Version: 0.4.29
Release: 1%{?dist} Release: 2%{?dist}
Summary: Rust bindings to libcurl for making HTTP requests Summary: Rust bindings to libcurl for making HTTP requests
# Upstream license specification: MIT # Upstream license specification: MIT
@ -16,7 +16,6 @@ URL: https://crates.io/crates/curl
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * No windows/osx # * No windows/osx
# * No static features
Patch0: curl-fix-metadata.diff Patch0: curl-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -44,7 +43,6 @@ which use "%{crate}" crate.
%license LICENSE %license LICENSE
%doc README.md %doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%exclude %{cargo_registry}/%{crate}-%{version_no_tilde}/{appveyor.yml,ci}
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -58,6 +56,18 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+force-system-lib-on-osx-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+force-system-lib-on-osx-devel %{_description}
This package contains library source intended for building other packages
which use "force-system-lib-on-osx" feature of "%{crate}" crate.
%files -n %{name}+force-system-lib-on-osx-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+http2-devel %package -n %{name}+http2-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -70,6 +80,18 @@ which use "http2" feature of "%{crate}" crate.
%files -n %{name}+http2-devel %files -n %{name}+http2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+mesalink-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mesalink-devel %{_description}
This package contains library source intended for building other packages
which use "mesalink" feature of "%{crate}" crate.
%files -n %{name}+mesalink-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+openssl-probe-devel %package -n %{name}+openssl-probe-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -130,6 +152,30 @@ which use "ssl" feature of "%{crate}" crate.
%files -n %{name}+ssl-devel %files -n %{name}+ssl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+static-curl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+static-curl-devel %{_description}
This package contains library source intended for building other packages
which use "static-curl" feature of "%{crate}" crate.
%files -n %{name}+static-curl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+static-ssl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+static-ssl-devel %{_description}
This package contains library source intended for building other packages
which use "static-ssl" feature of "%{crate}" crate.
%files -n %{name}+static-ssl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
@ -149,6 +195,9 @@ which use "ssl" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sun May 17 16:11:49 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.4.29-2
- Restore static features
* Wed Apr 29 2020 Josh Stone <jistone@redhat.com> - 0.4.29-1 * Wed Apr 29 2020 Josh Stone <jistone@redhat.com> - 0.4.29-1
- Update to 0.4.29 - Update to 0.4.29

Loading…
Cancel
Save