Update to 0.4.25

epel9
Josh Stone 5 years ago
parent 3056c4e5c7
commit 1f5d4f5505

1
.gitignore vendored

@ -7,3 +7,4 @@
/curl-0.4.19.crate
/curl-0.4.20.crate
/curl-0.4.22.crate
/curl-0.4.25.crate

@ -1,28 +1,28 @@
--- curl-0.4.22/Cargo.toml 1970-01-01T00:00:00+00:00
+++ curl-0.4.22/Cargo.toml 2019-06-03T17:41:26.142954+00:00
@@ -42,11 +42,8 @@
--- curl-0.4.25/Cargo.toml 1970-01-01T00:00:00+00:00
+++ curl-0.4.25/Cargo.toml 2019-11-23T00:18:29.474934+00:00
@@ -42,12 +42,8 @@
[features]
default = ["ssl"]
-force-system-lib-on-osx = ["curl-sys/force-system-lib-on-osx"]
http2 = ["curl-sys/http2"]
-mesalink = ["curl-sys/mesalink"]
ssl = ["openssl-sys", "openssl-probe", "curl-sys/ssl"]
-static-curl = ["curl-sys/static-curl"]
-static-ssl = ["curl-sys/static-ssl"]
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
version = "0.1.2"
optional = true
@@ -54,13 +51,7 @@
@@ -55,12 +51,7 @@
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
version = "0.9.43"
optional = true
-[target."cfg(target_env = \"msvc\")".dependencies.kernel32-sys]
-version = "0.2.2"
-[target."cfg(target_env = \"msvc\")".dependencies.schannel]
-version = "0.1.13"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.2.7"
-[target."cfg(target_env = \"msvc\")".dependencies.winapi]
-version = "0.3"
-features = ["libloaderapi", "wincrypt"]
[badges.appveyor]
repository = "alexcrichton/curl-rust"

@ -1,4 +1,4 @@
# Generated by rust2rpm
# Generated by rust2rpm 10
# Tests are run in infrastructure
%bcond_with check
%global debug_package %{nil}
@ -6,8 +6,8 @@
%global crate curl
Name: rust-%{crate}
Version: 0.4.22
Release: 2%{?dist}
Version: 0.4.25
Release: 1%{?dist}
Summary: Rust bindings to libcurl for making HTTP requests
# Upstream license specification: MIT
@ -20,20 +20,14 @@ Source: %{crates_source}
Patch0: curl-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: (crate(curl-sys) >= 0.4.18 with crate(curl-sys) < 0.5.0)
BuildRequires: (crate(curl-sys/ssl) >= 0.4.18 with crate(curl-sys/ssl) < 0.5.0)
BuildRequires: (crate(libc/default) >= 0.2.42 with crate(libc/default) < 0.3.0)
BuildRequires: (crate(openssl-probe/default) >= 0.1.2 with crate(openssl-probe/default) < 0.2.0)
BuildRequires: (crate(socket2/default) >= 0.3.7 with crate(socket2/default) < 0.4.0)
%if %{with check}
BuildRequires: (crate(mio-extras/default) >= 2.0.3 with crate(mio-extras/default) < 3.0.0)
BuildRequires: (crate(mio/default) >= 0.6.0 with crate(mio/default) < 0.7.0)
%endif
%global _description \
Rust bindings to libcurl for making HTTP requests.
%global _description %{expand:
Rust bindings to libcurl for making HTTP requests.}
%description %{_description}
@ -116,6 +110,9 @@ which use "ssl" feature of "%{crate}" crate.
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
@ -128,6 +125,9 @@ which use "ssl" feature of "%{crate}" crate.
%endif
%changelog
* Sat Nov 23 2019 Josh Stone <jistone@redhat.com> - 0.4.25-1
- Update to 0.4.25
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.22-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1 +1 @@
SHA512 (curl-0.4.22.crate) = fef61fa4e62bd38704b63de31ba02ab076067e4c292838cab994a2e51ec5be03f66611bb2c52ed13f113bc188d5f3f9abb9c74af52c0fdfc9f59e513c214dc6b
SHA512 (curl-0.4.25.crate) = c42efa6bcb5989c4f3a91629d0a547448ccce7fc8556b802ed2bdd10941cae25bb1ad15cd914024f1fdb0d1799ac2345fdc649b985b86eb87074b2b80e7c80d3

Loading…
Cancel
Save