Update to version 0.4.77+curl-8.10.1; Fixes RHBZ#2311749

epel10 imports/epel10/rust-curl-sys-0.4.77-1.el10
Fabio Valentini 5 months ago
parent 7d550bb460
commit fda42cb973
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -43,3 +43,4 @@
/curl-sys-0.4.72+curl-8.6.0.crate
/curl-sys-0.4.73+curl-8.8.0.crate
/curl-sys-0.4.74+curl-8.9.0.crate
/curl-sys-0.4.77+curl-8.10.1.crate

@ -1,17 +1,17 @@
From 21a769a9d06dc811652d9c405be4f92a06807164 Mon Sep 17 00:00:00 2001
From b20169c69e40a568c510e39b24ef5c844f81ce25 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Fri, 9 Aug 2024 13:36:02 +0200
Date: Mon, 7 Oct 2024 21:24:01 +0200
Subject: [PATCH] unconditionally use pkg-config to link with system libcurl
---
build.rs | 589 +------------------------------------------------------
1 file changed, 5 insertions(+), 584 deletions(-)
build.rs | 599 +------------------------------------------------------
1 file changed, 5 insertions(+), 594 deletions(-)
diff --git a/build.rs b/build.rs
index 7d9a661..497789c 100644
index fa57dd9..497789c 100644
--- a/build.rs
+++ b/build.rs
@@ -1,613 +1,34 @@
@@ -1,623 +1,34 @@
-use std::env;
-use std::fs;
-use std::path::{Path, PathBuf};
@ -19,6 +19,14 @@ index 7d9a661..497789c 100644
fn main() {
- println!("cargo:rerun-if-changed=curl");
- println!(
- "cargo:rustc-check-cfg=cfg(\
- libcurl_vendored,\
- link_libnghttp2,\
- link_libz,\
- link_openssl,\
- )"
- );
- let target = env::var("TARGET").unwrap();
- let windows = target.contains("windows");
-
@ -114,7 +122,7 @@ index 7d9a661..497789c 100644
- .replace("@LIBCURL_LIBS@", "")
- .replace("@SUPPORT_FEATURES@", "")
- .replace("@SUPPORT_PROTOCOLS@", "")
- .replace("@CURLVERSION@", "8.9.0"),
- .replace("@CURLVERSION@", "8.10.1"),
- )
- .unwrap();
-
@ -136,6 +144,7 @@ index 7d9a661..497789c 100644
- .define("CURL_DISABLE_TFTP", None)
- .define("CURL_STATICLIB", None)
- .define("ENABLE_IPV6", None)
- .define("HAVE_SOCKADDR_IN6_SIN6_SCOPE_ID", None)
- .define("HAVE_ASSERT_H", None)
- .define("OS", "\"unknown\"") // TODO
- .define("HAVE_ZLIB_H", None)
@ -296,6 +305,7 @@ index 7d9a661..497789c 100644
- // features, make sure we only compile one vtls.
- if cfg!(feature = "rustls") {
- cfg.define("USE_RUSTLS", None)
- .file("curl/lib/vtls/cipher_suite.c")
- .file("curl/lib/vtls/rustls.c")
- .include(env::var_os("DEP_RUSTLS_FFI_INCLUDE").unwrap());
- } else if cfg!(feature = "windows-static-ssl") {
@ -631,5 +641,5 @@ index 7d9a661..497789c 100644
- None
-}
--
2.46.0
2.46.2

@ -1,29 +1,21 @@
--- curl-sys-0.4.74+curl-8.9.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.74+curl-8.9.0/Cargo.toml 2024-08-09T11:34:01.724222+00:00
--- curl-sys-0.4.77+curl-8.10.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.77+curl-8.10.1/Cargo.toml 2024-10-07T19:20:21.308338+00:00
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "curl-sys"
-version = "0.4.74+curl-8.9.0"
+version = "0.4.74"
-version = "0.4.77+curl-8.10.1"
+version = "0.4.77"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "curl"
@@ -77,15 +77,10 @@
@@ -82,9 +82,4 @@
version = "0.9.64"
optional = true
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
-[target.'cfg(target_env = "msvc")'.build-dependencies.vcpkg]
-version = "0.2"
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.52"
-features = ["Win32_Networking_WinSock"]
-
[badges.appveyor]
repository = "alexcrichton/curl-rust"
[badges.travis-ci]
repository = "alexcrichton/curl-rust"
+
+

@ -1,6 +1,6 @@
--- curl-sys-0.4.74+curl-8.9.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.74+curl-8.9.0/Cargo.toml 2024-08-09T11:34:36.868398+00:00
@@ -33,20 +33,6 @@
--- curl-sys-0.4.77+curl-8.10.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.77+curl-8.10.1/Cargo.toml 2024-10-07T19:21:27.146697+00:00
@@ -38,20 +38,6 @@
[dependencies.libc]
version = "0.2.2"
@ -14,14 +14,14 @@
-default-features = false
-
-[dependencies.rustls-ffi]
-version = "0.13"
-version = "0.14"
-features = ["no_log_capture"]
-optional = true
-
[build-dependencies.cc]
version = "1.0"
@@ -55,23 +41,13 @@
@@ -60,23 +46,13 @@
[features]
default = ["ssl"]
@ -44,5 +44,5 @@
- "static-curl",
-]
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
[target.'cfg(all(unix, not(target_os = "macos")))'.dependencies.openssl-sys]
version = "0.9.64"

@ -3,10 +3,10 @@
%global debug_package %{nil}
%global crate curl-sys
%global upstream_version 0.4.74+curl-8.9.0
%global upstream_version 0.4.77+curl-8.10.1
Name: rust-curl-sys
Version: 0.4.74
Version: 0.4.77
Release: %autorelease
Summary: Native bindings to the libcurl library
@ -16,7 +16,6 @@ Source: %{crates_source %{crate} %{upstream_version}}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: curl-sys-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * remove curl version suffix from crate version
# * drop windows-specific features and dependencies
# * drop optional dependencies and unused features (libnghttp2, mesalink)
# * drop rustls support (rustls is not supported on all architectures)

@ -1,6 +1,5 @@
[package]
cargo-toml-patch-comments = [
"remove curl version suffix from crate version",
"drop windows-specific features and dependencies",
"drop optional dependencies and unused features (libnghttp2, mesalink)",
"drop rustls support (rustls is not supported on all architectures)",

@ -1 +1 @@
SHA512 (curl-sys-0.4.74+curl-8.9.0.crate) = 125e01702a85f33a9157d67930c92cd8af619d098c5ca98d820ed308d7931f851c395a278f54f57a243b8ae33305292c15ce9d6397b7e3726c6eefe90d3577f6
SHA512 (curl-sys-0.4.77+curl-8.10.1.crate) = c233786490b8e0342877bf8a20e6ec7916f8b8a4aa6e11da120a5b389d8d273bb57149ce89ac13c7bd678a03a387d76f1a1d0590de54e4c31735e7b1f2534fbd

Loading…
Cancel
Save