Update to version 0.4.52+curl-7.81.0; Fixes RHBZ#2038503

epel9
Fabio Valentini 3 years ago
parent a806ceab93
commit 90a27b3d5c
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -30,3 +30,4 @@
/curl-sys-0.4.45+curl-7.78.0.crate
/curl-sys-0.4.50+curl-7.79.1.crate
/curl-sys-0.4.51+curl-7.80.0.crate
/curl-sys-0.4.52+curl-7.81.0.crate

@ -1,15 +1,15 @@
--- curl-sys-0.4.51+curl-7.80.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.51+curl-7.80.0/Cargo.toml 2021-11-26T12:07:16.961079+00:00
--- curl-sys-0.4.52+curl-7.81.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.52+curl-7.81.0/Cargo.toml 2022-01-27T13:38:15.897909+00:00
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "curl-sys"
-version = "0.4.51+curl-7.80.0"
+version = "0.4.51"
-version = "0.4.52+curl-7.81.0"
+version = "0.4.52"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "curl"
@@ -28,20 +28,6 @@
@@ -28,25 +28,6 @@
[dependencies.libc]
version = "0.2.2"
@ -27,17 +27,24 @@
-features = ["client_apis", "error_strings", "tls13", "aesgcm", "chachapoly", "x25519", "ecdh", "ecdsa", "verifier"]
-optional = true
-default-features = false
-
-[dependencies.rustls-ffi]
-version = "0.8"
-features = ["no_log_capture"]
-optional = true
[build-dependencies.cc]
version = "1.0"
@@ -51,23 +37,17 @@
@@ -56,25 +37,18 @@
[features]
default = ["ssl"]
force-system-lib-on-osx = []
-http2 = ["libnghttp2-sys"]
+http2 = []
ntlm = []
poll_7_68_0 = []
protocol-ftp = []
-rustls = ["rustls-ffi"]
spnego = []
ssl = ["openssl-sys"]
static-curl = []

@ -1,12 +1,12 @@
# Generated by rust2rpm 18
# Generated by rust2rpm 20
%bcond_without check
%global debug_package %{nil}
%global crate curl-sys
%global upstream_version 0.4.51+curl-7.80.0
%global upstream_version 0.4.52+curl-7.81.0
Name: rust-%{crate}
Version: 0.4.51
Version: 0.4.52
Release: %autorelease
Summary: Native bindings to the libcurl library
@ -15,18 +15,16 @@ License: MIT
URL: https://crates.io/crates/curl-sys
Source: %{crates_source %{crate} %{upstream_version}}
# Initial patched metadata
# * Remove curl version from version field
# * No windows
# * Drop unused dependencies
# * No zlib-ng features
# * remove curl version suffix from crate version
# * drop windows-specific features and dependencies
# * drop optional dependencies and unused features (libnghttp2, mesalink)
# * drop rustls support (rustls is not supported on all architectures)
# * drop optional, unused zlib-ng support
Patch0: curl-sys-fix-metadata.diff
# Make static-curl/static-ssl features a noop, not for upstream
Patch0001: 0001-Make-static-curl-static-ssl-features-a-noop.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
@ -42,8 +40,8 @@ Requires: pkgconfig(libcurl)
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
@ -55,8 +53,8 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -67,8 +65,8 @@ BuildArch: noarch
%description -n %{name}+force-system-lib-on-osx-devel %{_description}
This package contains library source intended for building other packages
which use "force-system-lib-on-osx" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "force-system-lib-on-osx" feature of the "%{crate}" crate.
%files -n %{name}+force-system-lib-on-osx-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -79,20 +77,32 @@ BuildArch: noarch
%description -n %{name}+http2-devel %{_description}
This package contains library source intended for building other packages
which use "http2" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "http2" feature of the "%{crate}" crate.
%files -n %{name}+http2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+ntlm-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ntlm-devel %{_description}
This package contains library source intended for building other packages which
use the "ntlm" feature of the "%{crate}" crate.
%files -n %{name}+ntlm-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+openssl-sys-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+openssl-sys-devel %{_description}
This package contains library source intended for building other packages
which use "openssl-sys" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "openssl-sys" feature of the "%{crate}" crate.
%files -n %{name}+openssl-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -103,8 +113,8 @@ BuildArch: noarch
%description -n %{name}+poll_7_68_0-devel %{_description}
This package contains library source intended for building other packages
which use "poll_7_68_0" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "poll_7_68_0" feature of the "%{crate}" crate.
%files -n %{name}+poll_7_68_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -115,8 +125,8 @@ BuildArch: noarch
%description -n %{name}+protocol-ftp-devel %{_description}
This package contains library source intended for building other packages
which use "protocol-ftp" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "protocol-ftp" feature of the "%{crate}" crate.
%files -n %{name}+protocol-ftp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -127,8 +137,8 @@ BuildArch: noarch
%description -n %{name}+spnego-devel %{_description}
This package contains library source intended for building other packages
which use "spnego" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "spnego" feature of the "%{crate}" crate.
%files -n %{name}+spnego-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -139,8 +149,8 @@ BuildArch: noarch
%description -n %{name}+ssl-devel %{_description}
This package contains library source intended for building other packages
which use "ssl" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "ssl" feature of the "%{crate}" crate.
%files -n %{name}+ssl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -151,8 +161,8 @@ BuildArch: noarch
%description -n %{name}+static-curl-devel %{_description}
This package contains library source intended for building other packages
which use "static-curl" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "static-curl" feature of the "%{crate}" crate.
%files -n %{name}+static-curl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -163,8 +173,8 @@ BuildArch: noarch
%description -n %{name}+static-ssl-devel %{_description}
This package contains library source intended for building other packages
which use "static-ssl" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "static-ssl" feature of the "%{crate}" crate.
%files -n %{name}+static-ssl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -175,8 +185,8 @@ BuildArch: noarch
%description -n %{name}+upkeep_7_62_0-devel %{_description}
This package contains library source intended for building other packages
which use "upkeep_7_62_0" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "upkeep_7_62_0" feature of the "%{crate}" crate.
%files -n %{name}+upkeep_7_62_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

@ -1 +1 @@
SHA512 (curl-sys-0.4.51+curl-7.80.0.crate) = 3b4649eac943a6135dc12750817318f50b0cb1bf7f89113a550081b66329cabe0a8e0a88fddfad3a1742c5f32eef43eb4e48163ffae2cb1cf4136186ebf6b387
SHA512 (curl-sys-0.4.52+curl-7.81.0.crate) = 86967a065902b06fa00ca23c253e9915fd8e5db16fc5731b4327d6b2bd77ba5552ec96349070329ee15c2b32798b727275305a96e8720c0aef8b47e5a989e640

Loading…
Cancel
Save