Update to 0.4.28+curl-7.69.0

epel9
Josh Stone 5 years ago
parent e4407c2b20
commit 7c84fec5ee

1
.gitignore vendored

@ -19,3 +19,4 @@
/curl-sys-0.4.25.crate /curl-sys-0.4.25.crate
/curl-sys-0.4.26.crate /curl-sys-0.4.26.crate
/curl-sys-0.4.27.crate /curl-sys-0.4.27.crate
/curl-sys-0.4.28+curl-7.69.0.crate

@ -1,11 +1,20 @@
--- curl-sys-0.4.27/Cargo.toml 2020-02-28T16:20:12+00:00 --- curl-sys-0.4.28+curl-7.69.0/Cargo.toml 2020-03-04T15:34:09+00:00
+++ curl-sys-0.4.27/Cargo.toml 2020-02-29T04:26:12.760416+00:00 +++ curl-sys-0.4.28+curl-7.69.0/Cargo.toml 2020-03-04T21:59:22.238863+00:00
@@ -12,7 +12,7 @@
[package]
name = "curl-sys"
-version = "0.4.28+curl-7.69.0"
+version = "0.4.28"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "curl"
@@ -28,18 +28,9 @@ @@ -28,18 +28,9 @@
[dependencies.libc] [dependencies.libc]
version = "0.2.2" version = "0.2.2"
-[dependencies.libnghttp2-sys] -[dependencies.libnghttp2-sys]
-version = "0.1" -version = "0.1.3"
-optional = true -optional = true
- -
[dependencies.libz-sys] [dependencies.libz-sys]
@ -19,16 +28,18 @@
[build-dependencies.cc] [build-dependencies.cc]
version = "1.0" version = "1.0"
@@ -49,7 +40,7 @@ @@ -48,21 +39,13 @@
[features] [features]
default = ["ssl"] default = ["ssl"]
force-system-lib-on-osx = [] -force-system-lib-on-osx = []
-http2 = ["libnghttp2-sys"] -http2 = ["libnghttp2-sys"]
+http2 = [] +http2 = []
protocol-ftp = [] protocol-ftp = []
spnego = [] spnego = []
ssl = ["openssl-sys"] ssl = ["openssl-sys"]
@@ -58,11 +49,6 @@ -static-curl = []
-static-ssl = ["openssl-sys/vendored"]
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys] [target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
version = "0.9" version = "0.9"
optional = true optional = true

@ -3,17 +3,19 @@
%global debug_package %{nil} %global debug_package %{nil}
%global crate curl-sys %global crate curl-sys
%global upstream_version 0.4.28+curl-7.69.0
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.4.27 Version: 0.4.28
Release: 1%{?dist} Release: 1
Summary: Native bindings to the libcurl library Summary: Native bindings to the libcurl library
# Upstream license specification: MIT # Upstream license specification: MIT
License: MIT License: MIT
URL: https://crates.io/crates/curl-sys URL: https://crates.io/crates/curl-sys
Source: %{crates_source} Source: %{crates_source %{crate} %{upstream_version}}
# Initial patched metadata # Initial patched metadata
# * Remove curl version from version field
# * No windows # * No windows
# * libnghttp2-sys is only needed for bundled curl # * libnghttp2-sys is only needed for bundled curl
Patch0: curl-sys-fix-metadata.diff Patch0: curl-sys-fix-metadata.diff
@ -118,7 +120,7 @@ which use "ssl" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{upstream_version} -p1
# No bundled deps # No bundled deps
rm -vrf curl rm -vrf curl
%cargo_prep %cargo_prep
@ -139,6 +141,9 @@ echo 'pkgconfig(libcurl)'
%endif %endif
%changelog %changelog
* Wed Mar 04 2020 Josh Stone <jistone@redhat.com> - 0.4.28-1
- Update to 0.4.28+curl-7.69.0
* Sat Feb 29 2020 Josh Stone <jistone@redhat.com> - 0.4.27-1 * Sat Feb 29 2020 Josh Stone <jistone@redhat.com> - 0.4.27-1
- Update to 0.4.27 - Update to 0.4.27

@ -1 +1 @@
SHA512 (curl-sys-0.4.27.crate) = dcd044b509634b0b69dd586a9214b94e882f5dd89302a234c74aefed63723492afc30755cf771c8e16413d80e6be1cb72ff0042f738c0279b451809d3a4e60b0 SHA512 (curl-sys-0.4.28+curl-7.69.0.crate) = e963a7c2301e46c1fa063df38e4e178b6b416323dab49527de008fc7bda72e446bc3b52855bf2225bd770d328c755f747bae56089a0a7976bea4d6eeff9c01ef

Loading…
Cancel
Save