Update to version 0.4.59+curl-7.86.0; Fixes RHBZ#2138052

epel9
Fabio Valentini 2 years ago
parent 083649a6bd
commit 1a9d68892c
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -33,3 +33,4 @@
/curl-sys-0.4.52+curl-7.81.0.crate
/curl-sys-0.4.55+curl-7.83.1.crate
/curl-sys-0.4.56+curl-7.83.1.crate
/curl-sys-0.4.59+curl-7.86.0.crate

@ -0,0 +1,19 @@
--- curl-sys-0.4.59+curl-7.86.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.59+curl-7.86.0/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -73,16 +73,6 @@
version = "0.9"
optional = true
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
-version = "0.2"
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = [
- "winsock2",
- "ws2def",
-]
-
[badges.appveyor]
repository = "alexcrichton/curl-rust"

@ -1,11 +1,11 @@
--- curl-sys-0.4.56+curl-7.83.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.56+curl-7.83.1/Cargo.toml 2022-07-22T10:22:23.424531+00:00
--- curl-sys-0.4.59+curl-7.86.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.59+curl-7.86.0/Cargo.toml 2022-12-12T23:09:04.025792+00:00
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "curl-sys"
-version = "0.4.56+curl-7.83.1"
+version = "0.4.56"
-version = "0.4.59+curl-7.86.0"
+version = "0.4.59"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "curl"
@ -30,7 +30,7 @@
[build-dependencies.cc]
version = "1.0"
@@ -52,35 +38,20 @@
@@ -52,22 +38,17 @@
[features]
default = ["ssl"]
force-system-lib-on-osx = []
@ -47,6 +47,7 @@
-static-ssl = ["openssl-sys/vendored"]
+static-ssl = []
upkeep_7_62_0 = []
windows-static-ssl = []
-zlib-ng-compat = [
- "libz-sys/zlib-ng",
- "static-curl",
@ -54,17 +55,3 @@
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
version = "0.9"
optional = true
-
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
-version = "0.2"
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = [
- "winsock2",
- "ws2def",
-]
[badges.appveyor]
repository = "alexcrichton/curl-rust"

@ -1,30 +1,29 @@
# Generated by rust2rpm 21
# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}
%global crate curl-sys
%global upstream_version 0.4.56+curl-7.83.1
%global upstream_version 0.4.59+curl-7.86.0
Name: rust-%{crate}
Version: 0.4.56
Name: rust-curl-sys
Version: 0.4.59
Release: %autorelease
Summary: Native bindings to the libcurl library
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/curl-sys
Source: %{crates_source %{crate} %{upstream_version}}
# Initial patched metadata
# Automatically generated patch to strip foreign dependencies
Patch: curl-sys-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * remove curl version suffix from crate version
# * drop windows-specific features and dependencies
# * drop optional dependencies and unused features (libnghttp2, mesalink)
# * drop rustls support (rustls is not supported on all architectures)
# * drop optional, unused zlib-ng support
Patch0: curl-sys-fix-metadata.diff
Patch: curl-sys-fix-metadata.diff
# Make static-curl/static-ssl features a noop, not for upstream
Patch0001: 0001-Make-static-curl-static-ssl-features-a-noop.patch
ExclusiveArch: %{rust_arches}
Patch: 0001-Make-static-curl-static-ssl-features-a-noop.patch
BuildRequires: rust-packaging >= 21

@ -2,6 +2,7 @@
unwanted-features =
force-system-lib-on-osx
mesalink
windows-static-ssl
buildrequires =
pkgconfig(libcurl)
lib.requires =

@ -1 +1 @@
SHA512 (curl-sys-0.4.56+curl-7.83.1.crate) = 631de8e5740d076599d33723656129c3790e170ac108c91f2b9d7e4a954ece205685e0339fbb87ae3416156d3089d6fff8d514096f213b99fa43d14750b69c08
SHA512 (curl-sys-0.4.59+curl-7.86.0.crate) = 048c5dbc3e1870c9b205c107e006c7112d01f4f7f03eb301ad9ca06ef29d03b08a840717ccc45883f19f1f6734958301375365653ccc6e45ff99151bd5e03b3f

Loading…
Cancel
Save