Update to 3.1.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 3c0f85e1b8
commit 5bffcc56c2

1
.gitignore vendored

@ -1 +1,2 @@
/ctrlc-3.0.3.crate /ctrlc-3.0.3.crate
/ctrlc-3.1.0.crate

@ -1,64 +0,0 @@
From 6f9feb2f34ce539cd67850d708768352485946c6 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Thu, 4 Jan 2018 23:52:45 +0100
Subject: [PATCH] deps: update nix to 0.9
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
src/lib.rs | 16 ++++++++++++----
1 file changed, 12 insertions(+), 4 deletions(-)
diff --git a/src/lib.rs b/src/lib.rs
index db6b72e..91e8afb 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -95,13 +95,21 @@ mod platform {
static mut PIPE: (RawFd, RawFd) = (-1, -1);
- extern fn os_handler(_: nix::c_int) {
+ extern fn os_handler(_: nix::libc::c_int) {
// Assuming this always succeeds. Can't really handle errors in any meaningful way.
unsafe {
unistd::write(PIPE.1, &[0u8]).is_ok();
}
}
+ fn nix_err_to_io_err(err: nix::Error) -> io::Error {
+ if let nix::Error::Sys(err_no) = err {
+ io::Error::from(err_no)
+ } else {
+ panic!("unexpected nix error type: {:?}", err)
+ }
+ }
+
/// Register os signal handler.
///
/// Must be called before calling [`block_ctrl_c()`](fn.block_ctrl_c.html)
@@ -115,12 +123,12 @@ mod platform {
use self::nix::fcntl;
use self::nix::sys::signal;
- PIPE = unistd::pipe2(fcntl::O_CLOEXEC).map_err(|e| Error::System(e.into()))?;
+ PIPE = unistd::pipe2(fcntl::O_CLOEXEC).map_err(|e| Error::System(nix_err_to_io_err(e)))?;
let close_pipe = |e: nix::Error| -> Error {
unistd::close(PIPE.1).is_ok();
unistd::close(PIPE.0).is_ok();
- Error::System(e.into())
+ Error::System(nix_err_to_io_err(e))
};
// Make sure we never block on write in the os handler.
@@ -172,7 +180,7 @@ mod platform {
Ok(1) => break,
Ok(_) => return Err(Error::System(io::ErrorKind::UnexpectedEof.into()).into()),
Err(nix::Error::Sys(nix::Errno::EINTR)) => {},
- Err(e) => return Err(Error::System(e.into())),
+ Err(e) => return Err(Error::System(nix_err_to_io_err(e))),
}
}
--
2.15.1

@ -1,17 +0,0 @@
--- ctrlc-3.0.3/Cargo.toml 1970-01-01T01:00:00+01:00
+++ ctrlc-3.0.3/Cargo.toml 2018-01-04T23:55:57.200531+01:00
@@ -26,13 +26,7 @@
path = "src/tests.rs"
harness = false
[dependencies.nix]
-version = "0.8"
-
-[dependencies.winapi]
-version = "0.2"
-
-[dependencies.kernel32-sys]
-version = "0.2"
+version = "0.9"
[features]
termination = []

@ -0,0 +1,11 @@
--- ctrlc-3.1.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ ctrlc-3.1.0/Cargo.toml 2018-01-15T09:29:12.866855+01:00
@@ -30,8 +30,3 @@
termination = []
[target."cfg(unix)".dependencies.nix]
version = "0.9"
-[target."cfg(windows)".dependencies.kernel32-sys]
-version = "0.2"
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.2"

@ -5,21 +5,16 @@
%global crate ctrlc %global crate ctrlc
Name: rust-%{crate} Name: rust-%{crate}
Version: 3.0.3 Version: 3.1.0
Release: 2%{?dist} Release: 1%{?dist}
Summary: Easy Ctrl-C handler for Rust projects Summary: Easy Ctrl-C handler for Rust projects
# License files are in upstream, but not yet in release
# https://github.com/Detegr/rust-ctrlc/commit/587c77eb89b6e0a312ef066445ad8253ca08c785
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/ctrlc URL: https://crates.io/crates/ctrlc
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata # Initial patched metadata
# * No windows # * No windows
# * Bump nix to 0.9, https://github.com/Detegr/rust-ctrlc/pull/35 Patch0: ctrlc-3.1.0-fix-metadata.diff
Patch0: ctrlc-3.0.3-fix-metadata.diff
# Make it work with nix v0.9
Patch1: 0001-deps-update-nix-to-0.9.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -56,11 +51,15 @@ which use %{crate} from crates.io.
%endif %endif
%files devel %files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md %doc README.md
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml %exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
%changelog %changelog
* Mon Jan 15 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.1.0-1
- Update to 3.1.0
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.0.3-2 * Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.0.3-2
- Rebuild for rust-packaging v5 - Rebuild for rust-packaging v5

@ -1 +1 @@
SHA512 (ctrlc-3.0.3.crate) = 4ea771c4ee780ef3dc45377a4abd6afb705faff7e50bd789ffa7c178da180354eb8889832d6bef09a7bbb23da540b40affb28e1cc601dc4b0c440795c4708623 SHA512 (ctrlc-3.1.0.crate) = f06cc8120873289cd2c34d4209ee33dfbaada9c57bfb8d126a6cabaca9c9dbb705a0582df76488771a418eb078dc2074fce6a6b1ffbde4c32e38069af418cd1c

Loading…
Cancel
Save