Update serde_bytes to 0.11

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 409f87f6ac
commit 5d7cdafbbf
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -0,0 +1,28 @@
From 58c6ccbda090f72be62b31e840e1808c9b49265f Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sun, 12 May 2019 08:15:07 +0200
Subject: [PATCH] chore: Update serde_bytes to 0.11
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
src/deserializer.rs | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/deserializer.rs b/src/deserializer.rs
index 9d1d980..6ab72ae 100644
--- a/src/deserializer.rs
+++ b/src/deserializer.rs
@@ -1014,8 +1014,8 @@ mod tests {
#[test]
fn bytes() {
- let got: Vec<u8> = de::<ByteBuf>(&["foobar"]).unwrap().into();
- assert_eq!(got, b"foobar".to_vec());
+ let got = de::<ByteBuf>(&["foobar"]).unwrap();
+ assert_eq!(got, b"foobar");
}
#[test]
--
2.21.0

@ -0,0 +1,11 @@
--- csv-1.0.7/Cargo.toml 1970-01-01T00:00:00+00:00
+++ csv-1.0.7/Cargo.toml 2019-05-12T06:37:15.185944+00:00
@@ -43,7 +43,7 @@
[dependencies.serde]
version = "1.0.55"
[dev-dependencies.serde_bytes]
-version = "0.10.4"
+version = "0.11"
[dev-dependencies.serde_derive]
version = "1.0.55"

@ -1,5 +1,4 @@
# Generated by rust2rpm # Generated by rust2rpm-9-1.fc31
# * Tests are run in infrastructure
%bcond_with check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
@ -7,13 +6,18 @@
Name: rust-%{crate} Name: rust-%{crate}
Version: 1.0.7 Version: 1.0.7
Release: 1%{?dist} Release: 2%{?dist}
Summary: Fast CSV parsing with support for serde Summary: Fast CSV parsing with support for serde
# Upstream license specification: Unlicense/MIT # Upstream license specification: Unlicense/MIT
License: Unlicense or MIT License: Unlicense or MIT
URL: https://crates.io/crates/csv URL: https://crates.io/crates/csv
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * Update serde_bytes to 0.11, https://github.com/BurntSushi/rust-csv/pull/154
Patch0: csv-fix-metadata.diff
# Make it work with new serde_bytes
Patch0001: 0001-chore-Update-serde_bytes-to-0.11.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -23,7 +27,7 @@ BuildRequires: (crate(itoa/default) >= 0.4.3 with crate(itoa/default) < 0.5.0)
BuildRequires: (crate(ryu/default) >= 0.2.7 with crate(ryu/default) < 0.3.0) BuildRequires: (crate(ryu/default) >= 0.2.7 with crate(ryu/default) < 0.3.0)
BuildRequires: (crate(serde/default) >= 1.0.55 with crate(serde/default) < 2.0.0) BuildRequires: (crate(serde/default) >= 1.0.55 with crate(serde/default) < 2.0.0)
%if %{with check} %if %{with check}
BuildRequires: (crate(serde_bytes/default) >= 0.10.4 with crate(serde_bytes/default) < 0.11.0) BuildRequires: (crate(serde_bytes/default) >= 0.11.0 with crate(serde_bytes/default) < 0.12.0)
BuildRequires: (crate(serde_derive/default) >= 1.0.55 with crate(serde_derive/default) < 2.0.0) BuildRequires: (crate(serde_derive/default) >= 1.0.55 with crate(serde_derive/default) < 2.0.0)
%endif %endif
@ -74,6 +78,9 @@ which use "default" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sun May 12 08:37:15 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.7-2
- Update serde_bytes to 0.11
* Mon Apr 15 2019 Josh Stone <jistone@redhat.com> - 1.0.7-1 * Mon Apr 15 2019 Josh Stone <jistone@redhat.com> - 1.0.7-1
- Update to 1.0.7 - Update to 1.0.7

Loading…
Cancel
Save