parent
27d6c272ca
commit
7f384f8492
@ -0,0 +1 @@
|
||||
/crypto-mac-0.7.0.crate
|
@ -0,0 +1,11 @@
|
||||
--- crypto-mac-0.7.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ crypto-mac-0.7.0/Cargo.toml 2019-03-13T23:39:35.767228+01:00
|
||||
@@ -30,7 +30,7 @@
|
||||
version = "0.12"
|
||||
|
||||
[dependencies.subtle]
|
||||
-version = "1"
|
||||
+version = "2"
|
||||
default-features = false
|
||||
|
||||
[features]
|
@ -0,0 +1,109 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate crypto-mac
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.7.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Trait for Message Authentication Code (MAC) algorithms
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/crypto-mac
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * Update subtle to 2, https://github.com/RustCrypto/traits/commit/2ed5d5a3a254c61c60cd0cf14931841b6f5c27ef
|
||||
Patch0: crypto-mac-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
BuildRequires: (crate(generic-array/default) >= 0.12.0 with crate(generic-array/default) < 0.13.0)
|
||||
BuildRequires: (crate(subtle) >= 2.0.0 with crate(subtle) < 3.0.0)
|
||||
|
||||
%global _description \
|
||||
Trait for Message Authentication Code (MAC) algorithms.
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||
|
||||
%package -n %{name}+blobby-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+blobby-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "blobby" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+blobby-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dev-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dev-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "dev" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dev-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "std" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Mar 13 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.0-1
|
||||
- Initial package
|
@ -0,0 +1 @@
|
||||
SHA512 (crypto-mac-0.7.0.crate) = 7297396fc06aae578644d47c8ef1053895e0a29d1c007f303631166cf12711f106eb91c9c11d01497e7a85fb461b84a16d2e0f1020444ab16fb4b8f2dfee18b1
|
@ -0,0 +1 @@
|
||||
1
|
@ -0,0 +1,5 @@
|
||||
---
|
||||
standard-inventory-qcow2:
|
||||
qemu:
|
||||
# `cargo test` usually eats more than 1G.
|
||||
m: 4G
|
@ -0,0 +1,13 @@
|
||||
---
|
||||
- hosts: localhost
|
||||
roles:
|
||||
- role: standard-test-basic
|
||||
tags:
|
||||
- classic
|
||||
repositories:
|
||||
- repo: "https://src.fedoraproject.org/tests/rust.git"
|
||||
dest: rust
|
||||
tests:
|
||||
- rust/cargo-test
|
||||
environment:
|
||||
pkg: rust-crypto-mac
|
Loading…
Reference in new issue