epel9
imports/e9/rust-crypto-bigint0.2-0.2.11-1.el9
parent
9a738df647
commit
21cebd9349
@ -0,0 +1 @@
|
||||
/crypto-bigint-0.2.11.crate
|
@ -1,3 +0,0 @@
|
||||
# rust-crypto-bigint0.2
|
||||
|
||||
The rust-crypto-bigint0.2 package
|
@ -0,0 +1,21 @@
|
||||
--- crypto-bigint-0.2.11/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ crypto-bigint-0.2.11/Cargo.toml 2023-05-30T13:12:08.521080+00:00
|
||||
@@ -32,17 +32,12 @@
|
||||
version = "0.6"
|
||||
optional = true
|
||||
|
||||
-[dependencies.rlp]
|
||||
-version = "0.5"
|
||||
-optional = true
|
||||
-default-features = false
|
||||
-
|
||||
[dependencies.subtle]
|
||||
version = "2.4"
|
||||
default-features = false
|
||||
|
||||
[dependencies.zeroize]
|
||||
-version = ">=1, <1.5"
|
||||
+version = "1"
|
||||
optional = true
|
||||
default-features = false
|
||||
[dev-dependencies.hex-literal]
|
@ -0,0 +1,137 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate crypto-bigint
|
||||
|
||||
Name: rust-crypto-bigint0.2
|
||||
Version: 0.2.11
|
||||
Release: %autorelease
|
||||
Summary: Pure Rust bigint implementation for use in cryptographic applications
|
||||
|
||||
License: Apache-2.0 OR MIT
|
||||
URL: https://crates.io/crates/crypto-bigint
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop optional rlp dependency (not packaged yet)
|
||||
# * relax zeroize dependency
|
||||
Patch: crypto-bigint-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Pure Rust implementation of a big integer library which has been
|
||||
designed from the ground-up for use in cryptographic applications.
|
||||
Provides constant-time, no_std-friendly implementations of modern
|
||||
formulas using const generics.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+alloc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+alloc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "alloc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+alloc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+generic-array-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+generic-array-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "generic-array" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+generic-array-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rand-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rand-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rand" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rand-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rand_core-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rand_core-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rand_core" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rand_core-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+zeroize-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+zeroize-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "zeroize" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+zeroize-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue