import rust-crypto-bigint-0.5.5-3.el10

i10ce changed/i10ce/rust-crypto-bigint-0.5.5-3.el10
MSVSphere Packaging Team 2 months ago
commit 2b537c312c
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/crypto-bigint-0.5.5.crate

@ -0,0 +1 @@
901233d47ab0e93855608889ccf3ebbe2cc70c56 SOURCES/crypto-bigint-0.5.5.crate

@ -0,0 +1,25 @@
--- crypto-bigint-0.5.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ crypto-bigint-0.5.5/Cargo.toml 2023-11-25T11:11:59.011894+00:00
@@ -63,11 +63,6 @@
version = "0.6.4"
optional = true
-[dependencies.rlp]
-version = "0.5"
-optional = true
-default-features = false
-
[dependencies.serdect]
version = "0.2"
optional = true
@@ -84,10 +79,6 @@
[dev-dependencies.bincode]
version = "1"
-
-[dev-dependencies.criterion]
-version = "0.5"
-features = ["html_reports"]
[dev-dependencies.hex-literal]
version = "0.4"

@ -0,0 +1,3 @@
[package]
summary = "Pure Rust bigint implementation for use in cryptographic applications"

@ -0,0 +1,220 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.2)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 3;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate crypto-bigint
Name: rust-crypto-bigint
Version: 0.5.5
Release: %autorelease
Summary: Pure Rust bigint implementation for use in cryptographic applications
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/crypto-bigint
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop optional rlp dependency (not packaged yet)
# * drop unused, benchmark-only criterion dev-dependency
Patch: crypto-bigint-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Pure Rust implementation of a big integer library which has been
designed from the ground-up for use in cryptographic applications.
Provides constant-time, no_std-friendly implementations of modern
formulas using const generics.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/SECURITY.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+der-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+der-devel %{_description}
This package contains library source intended for building other packages which
use the "der" feature of the "%{crate}" crate.
%files -n %{name}+der-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+extra-sizes-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+extra-sizes-devel %{_description}
This package contains library source intended for building other packages which
use the "extra-sizes" feature of the "%{crate}" crate.
%files -n %{name}+extra-sizes-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+generic-array-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+generic-array-devel %{_description}
This package contains library source intended for building other packages which
use the "generic-array" feature of the "%{crate}" crate.
%files -n %{name}+generic-array-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand_core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand_core-devel %{_description}
This package contains library source intended for building other packages which
use the "rand_core" feature of the "%{crate}" crate.
%files -n %{name}+rand_core-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zeroize-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zeroize-devel %{_description}
This package contains library source intended for building other packages which
use the "zeroize" feature of the "%{crate}" crate.
%files -n %{name}+zeroize-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.5.5-3
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sat Nov 25 2023 Fabio Valentini <decathorpe@gmail.com> - 0.5.5-1
- Update to version 0.5.5; Fixes RHBZ#2250485
* Mon Nov 13 2023 Fabio Valentini <decathorpe@gmail.com> - 0.5.4-1
- Update to version 0.5.4; Fixes RHBZ#2249443
* Tue Sep 05 2023 Fabio Valentini <decathorpe@gmail.com> - 0.5.3-1
- Update to version 0.5.3; Fixes RHBZ#2237332
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Wed Jun 07 2023 Fabio Valentini <decathorpe@gmail.com> - 0.5.2-1
- Update to version 0.5.2; Fixes RHBZ#2082961
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.11-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.11-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.11-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Mon Dec 13 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.11-1
- Initial import (#2031169)
## END: Generated by rpmautospec
Loading…
Cancel
Save