parent
211a0fe4e2
commit
0958d51c9b
@ -0,0 +1 @@
|
||||
/crossterm-0.26.1.crate
|
@ -0,0 +1,15 @@
|
||||
--- crossterm-0.26.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ crossterm-0.26.1/Cargo.toml 2023-10-24T10:33:58.778759+00:00
|
||||
@@ -110,12 +110,3 @@
|
||||
version = "0.2.3"
|
||||
features = ["support-v0_8"]
|
||||
|
||||
-[target."cfg(windows)".dependencies.crossterm_winapi]
|
||||
-version = "0.9"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3.9"
|
||||
-features = [
|
||||
- "winuser",
|
||||
- "winerror",
|
||||
-]
|
@ -0,0 +1,143 @@
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate crossterm
|
||||
|
||||
Name: rust-crossterm0.26
|
||||
Version: 0.26.1
|
||||
Release: %autorelease
|
||||
Summary: Crossplatform terminal library for manipulating terminals
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/crossterm
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: crossterm-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
A crossplatform terminal library for manipulating terminals.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+bracketed-paste-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+bracketed-paste-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "bracketed-paste" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+bracketed-paste-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+event-stream-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+event-stream-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "event-stream" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+event-stream-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+filedescriptor-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+filedescriptor-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "filedescriptor" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+filedescriptor-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-core-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-core-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures-core" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-core-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+use-dev-tty-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+use-dev-tty-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "use-dev-tty" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+use-dev-tty-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue