commit
b72bcfc055
Binary file not shown.
@ -0,0 +1,12 @@
|
||||
--- crossterm-0.19.0/Cargo.toml 2020-12-28T10:05:26+00:00
|
||||
+++ crossterm-0.19.0/Cargo.toml 2021-08-29T21:56:20.118113+00:00
|
||||
@@ -81,9 +81,3 @@
|
||||
[target."cfg(unix)".dependencies.signal-hook]
|
||||
version = "0.1.15"
|
||||
features = ["mio-0_7-support"]
|
||||
-[target."cfg(windows)".dependencies.crossterm_winapi]
|
||||
-version = "0.7.0"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3.9"
|
||||
-features = ["winuser"]
|
@ -0,0 +1,132 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.0)
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 3;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 18
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate crossterm
|
||||
|
||||
Name: rust-%{crate}0.19
|
||||
Version: 0.19.0
|
||||
Release: %autorelease
|
||||
Summary: Crossplatform terminal library for manipulating terminals
|
||||
|
||||
# Upstream license specification: MIT
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/crossterm
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * drop windows-specific dependencies
|
||||
Patch0: crossterm-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Crossplatform terminal library for manipulating terminals.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%doc README.md CHANGELOG.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+event-stream-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+event-stream-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "event-stream" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+event-stream-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-core-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-core-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "futures-core" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-core-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "serde" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.19.0-3
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.19.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.19.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Sep 03 2021 Fabio Valentini <decathorpe@gmail.com> 0.19.0-1
|
||||
- Initial import (crossterm 0.19 compat package)
|
Loading…
Reference in new issue