Update to 0.14.1

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 5 years ago
parent d431be9edd
commit fa3ba0f365
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -10,3 +10,4 @@
/crossterm-0.10.1.crate /crossterm-0.10.1.crate
/crossterm-0.10.2.crate /crossterm-0.10.2.crate
/crossterm-0.13.3.crate /crossterm-0.13.3.crate
/crossterm-0.14.1.crate

@ -1,27 +1,12 @@
--- crossterm-0.13.3/Cargo.toml 1970-01-01T00:00:00+00:00 --- crossterm-0.14.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ crossterm-0.13.3/Cargo.toml 2019-12-11T18:34:59.841113+00:00 +++ crossterm-0.14.1/Cargo.toml 2019-12-27T09:27:17.055358+00:00
@@ -37,11 +37,11 @@ @@ -71,9 +71,3 @@
optional = true [target."cfg(unix)".dependencies.signal-hook]
version = "0.1.12"
[features] features = ["mio-support"]
-cursor = ["lazy_static", "input", "winapi/wincon", "winapi/winnt", "winapi/minwindef"]
+cursor = ["lazy_static", "input"]
default = ["cursor", "style", "terminal", "screen", "input"]
-input = ["mio", "lazy_static", "screen", "winapi/winnt", "winapi/winuser"]
-screen = ["lazy_static", "winapi/wincon", "winapi/minwindef"]
-style = ["lazy_static", "winapi/wincon"]
+input = ["mio", "lazy_static", "screen"]
+screen = ["lazy_static"]
+style = ["lazy_static"]
terminal = ["cursor"]
[target."cfg(unix)".dependencies.libc]
version = "0.2.51"
@@ -49,8 +49,3 @@
[target."cfg(unix)".dependencies.mio]
version = "0.6.19"
optional = true
-[target."cfg(windows)".dependencies.crossterm_winapi] -[target."cfg(windows)".dependencies.crossterm_winapi]
-version = "0.4.0" -version = "0.5.1"
- -
-[target."cfg(windows)".dependencies.winapi] -[target."cfg(windows)".dependencies.winapi]
-version = "0.3.8" -version = "0.3.8"
-features = ["winuser"]

@ -1,11 +1,11 @@
# Generated by rust2rpm 11 # Generated by rust2rpm 13
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate crossterm %global crate crossterm
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.13.3 Version: 0.14.1
Release: 1%{?dist} Release: 1%{?dist}
Summary: Crossplatform terminal library for manipulating terminals Summary: Crossplatform terminal library for manipulating terminals
@ -41,7 +41,7 @@ which use "%{crate}" crate.
%files devel %files devel
%license LICENSE %license LICENSE
%doc README.md CHANGELOG.md %doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -53,67 +53,31 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate. which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+cursor-devel %package -n %{name}+event-stream-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+cursor-devel %{_description} %description -n %{name}+event-stream-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "cursor" feature of "%{crate}" crate. which use "event-stream" feature of "%{crate}" crate.
%files -n %{name}+cursor-devel %files -n %{name}+event-stream-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+input-devel %package -n %{name}+futures-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+input-devel %{_description} %description -n %{name}+futures-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "input" feature of "%{crate}" crate. which use "futures" feature of "%{crate}" crate.
%files -n %{name}+input-devel %files -n %{name}+futures-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+lazy_static-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lazy_static-devel %{_description}
This package contains library source intended for building other packages
which use "lazy_static" feature of "%{crate}" crate.
%files -n %{name}+lazy_static-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+mio-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mio-devel %{_description}
This package contains library source intended for building other packages
which use "mio" feature of "%{crate}" crate.
%files -n %{name}+mio-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+screen-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+screen-devel %{_description}
This package contains library source intended for building other packages
which use "screen" feature of "%{crate}" crate.
%files -n %{name}+screen-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
@ -125,31 +89,7 @@ This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate. which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+style-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+style-devel %{_description}
This package contains library source intended for building other packages
which use "style" feature of "%{crate}" crate.
%files -n %{name}+style-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+terminal-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+terminal-devel %{_description}
This package contains library source intended for building other packages
which use "terminal" feature of "%{crate}" crate.
%files -n %{name}+terminal-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
@ -170,6 +110,9 @@ which use "terminal" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Fri Dec 27 10:27:17 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.14.1-1
- Update to 0.14.1
* Wed Dec 11 19:34:59 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.13.3-1 * Wed Dec 11 19:34:59 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.13.3-1
- Update to 0.13.3 - Update to 0.13.3

@ -1 +1 @@
SHA512 (crossterm-0.13.3.crate) = d5a5cc9ca54d65545c3c8e3ba6a33c0c36d85c26f3d27be496476d52e2e0fcf89d4a979b7f0085cac0fc2d5c5bd63f7fe51dda3d87fcc4e4f6c713a66b826769 SHA512 (crossterm-0.14.1.crate) = f52972929459174dd8603fd32ba3fbbe070f82622e71d5063a24c64e8387e5a9eb4477727572c4c4f4efb5297aa56424684eaf7662ae21f0497a2593c8ef96b5

Loading…
Cancel
Save