Update to 0.13.3

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 5 years ago
parent 4ab324143b
commit d431be9edd
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -9,3 +9,4 @@
/crossterm-0.9.6.crate /crossterm-0.9.6.crate
/crossterm-0.10.1.crate /crossterm-0.10.1.crate
/crossterm-0.10.2.crate /crossterm-0.10.2.crate
/crossterm-0.13.3.crate

@ -0,0 +1,27 @@
--- crossterm-0.13.3/Cargo.toml 1970-01-01T00:00:00+00:00
+++ crossterm-0.13.3/Cargo.toml 2019-12-11T18:34:59.841113+00:00
@@ -37,11 +37,11 @@
optional = true
[features]
-cursor = ["lazy_static", "input", "winapi/wincon", "winapi/winnt", "winapi/minwindef"]
+cursor = ["lazy_static", "input"]
default = ["cursor", "style", "terminal", "screen", "input"]
-input = ["mio", "lazy_static", "screen", "winapi/winnt", "winapi/winuser"]
-screen = ["lazy_static", "winapi/wincon", "winapi/minwindef"]
-style = ["lazy_static", "winapi/wincon"]
+input = ["mio", "lazy_static", "screen"]
+screen = ["lazy_static"]
+style = ["lazy_static"]
terminal = ["cursor"]
[target."cfg(unix)".dependencies.libc]
version = "0.2.51"
@@ -49,8 +49,3 @@
[target."cfg(unix)".dependencies.mio]
version = "0.6.19"
optional = true
-[target."cfg(windows)".dependencies.crossterm_winapi]
-version = "0.4.0"
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.8"

@ -1,11 +1,11 @@
# Generated by rust2rpm 10 # Generated by rust2rpm 11
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate crossterm %global crate crossterm
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.10.2 Version: 0.13.3
Release: 1%{?dist} Release: 1%{?dist}
Summary: Crossplatform terminal library for manipulating terminals Summary: Crossplatform terminal library for manipulating terminals
@ -13,6 +13,9 @@ Summary: Crossplatform terminal library for manipulating terminals
License: MIT License: MIT
URL: https://crates.io/crates/crossterm URL: https://crates.io/crates/crossterm
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * No windows
Patch0: crossterm-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
@ -37,7 +40,7 @@ which use "%{crate}" crate.
%files devel %files devel
%license LICENSE %license LICENSE
%doc README.md %doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
@ -52,100 +55,76 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+crossterm_cursor-devel %package -n %{name}+cursor-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+crossterm_cursor-devel %{_description}
This package contains library source intended for building other packages
which use "crossterm_cursor" feature of "%{crate}" crate.
%files -n %{name}+crossterm_cursor-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+crossterm_input-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+crossterm_input-devel %{_description}
This package contains library source intended for building other packages
which use "crossterm_input" feature of "%{crate}" crate.
%files -n %{name}+crossterm_input-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+crossterm_screen-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+crossterm_screen-devel %{_description} %description -n %{name}+cursor-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "crossterm_screen" feature of "%{crate}" crate. which use "cursor" feature of "%{crate}" crate.
%files -n %{name}+crossterm_screen-devel %files -n %{name}+cursor-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+crossterm_style-devel %package -n %{name}+input-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+crossterm_style-devel %{_description} %description -n %{name}+input-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "crossterm_style" feature of "%{crate}" crate. which use "input" feature of "%{crate}" crate.
%files -n %{name}+crossterm_style-devel %files -n %{name}+input-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+crossterm_terminal-devel %package -n %{name}+lazy_static-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+crossterm_terminal-devel %{_description} %description -n %{name}+lazy_static-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "crossterm_terminal" feature of "%{crate}" crate. which use "lazy_static" feature of "%{crate}" crate.
%files -n %{name}+crossterm_terminal-devel %files -n %{name}+lazy_static-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+cursor-devel %package -n %{name}+mio-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+cursor-devel %{_description} %description -n %{name}+mio-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "cursor" feature of "%{crate}" crate. which use "mio" feature of "%{crate}" crate.
%files -n %{name}+cursor-devel %files -n %{name}+mio-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+input-devel %package -n %{name}+screen-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+input-devel %{_description} %description -n %{name}+screen-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "input" feature of "%{crate}" crate. which use "screen" feature of "%{crate}" crate.
%files -n %{name}+input-devel %files -n %{name}+screen-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+screen-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+screen-devel %{_description} %description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "screen" feature of "%{crate}" crate. which use "serde" feature of "%{crate}" crate.
%files -n %{name}+screen-devel %files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+style-devel %package -n %{name}+style-devel
@ -191,6 +170,9 @@ which use "terminal" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Wed Dec 11 19:34:59 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.13.3-1
- Update to 0.13.3
* Sat Aug 03 16:37:21 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.10.2-1 * Sat Aug 03 16:37:21 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.10.2-1
- Update to 0.10.2 - Update to 0.10.2

@ -1 +1 @@
SHA512 (crossterm-0.10.2.crate) = eaf37b33fa7ab01e90b6e290e69193b99246c8dcc94a6c1248b7bbc7a5444bd0b3fb41f4daf630775fd808fa55f08213b63e2130cdc4f70607cc765814f26b93 SHA512 (crossterm-0.13.3.crate) = d5a5cc9ca54d65545c3c8e3ba6a33c0c36d85c26f3d27be496476d52e2e0fcf89d4a979b7f0085cac0fc2d5c5bd63f7fe51dda3d87fcc4e4f6c713a66b826769

Loading…
Cancel
Save