Update to version 0.27.0; Fixes RHBZ#2229490

epel9
Fabio Valentini 1 year ago
parent b110f58387
commit 25617d0fdf
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -23,3 +23,4 @@
/crossterm-0.22.1.crate /crossterm-0.22.1.crate
/crossterm-0.25.0.crate /crossterm-0.25.0.crate
/crossterm-0.26.1.crate /crossterm-0.26.1.crate
/crossterm-0.27.0.crate

@ -1,3 +0,0 @@
# rust-crossterm
The rust-crossterm package

@ -1,11 +1,21 @@
--- crossterm-0.26.1/Cargo.toml 1970-01-01T00:00:01+00:00 --- crossterm-0.27.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ crossterm-0.26.1/Cargo.toml 2023-05-19T00:57:20.593988+00:00 +++ crossterm-0.27.0/Cargo.toml 2023-10-24T10:32:30.950527+00:00
@@ -110,12 +110,3 @@ @@ -143,8 +143,6 @@
version = "0.2.3" ]
use-dev-tty = ["filedescriptor"]
windows = [
- "dep:winapi",
- "dep:crossterm_winapi",
]
[target."cfg(unix)".dependencies.filedescriptor]
@@ -168,14 +166,3 @@
features = ["support-v0_8"] features = ["support-v0_8"]
optional = true
-[target."cfg(windows)".dependencies.crossterm_winapi] -[target."cfg(windows)".dependencies.crossterm_winapi]
-version = "0.9" -version = "0.9.1"
-optional = true
- -
-[target."cfg(windows)".dependencies.winapi] -[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9" -version = "0.3.9"
@ -13,3 +23,4 @@
- "winuser", - "winuser",
- "winerror", - "winerror",
-] -]
-optional = true

@ -0,0 +1,19 @@
--- crossterm-0.27.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ crossterm-0.27.0/Cargo.toml 2023-10-24T10:32:41.861215+00:00
@@ -125,7 +125,6 @@
bracketed-paste = []
default = [
"bracketed-paste",
- "windows",
"events",
]
event-stream = [
@@ -142,8 +141,6 @@
"bitflags/serde",
]
use-dev-tty = ["filedescriptor"]
-windows = [
-]
[target."cfg(unix)".dependencies.filedescriptor]
version = "0.8"

@ -1,21 +1,24 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate crossterm %global crate crossterm
Name: rust-crossterm Name: rust-crossterm
Version: 0.26.1 Version: 0.27.0
Release: %autorelease Release: %autorelease
Summary: Crossplatform terminal library for manipulating terminals Summary: Crossplatform terminal library for manipulating terminals
License: MIT License: MIT
URL: https://crates.io/crates/crossterm URL: https://crates.io/crates/crossterm
Source: %{crates_source} Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies # Automatically generated patch to strip dependencies and normalize metadata
Patch: crossterm-fix-metadata-auto.diff Patch: crossterm-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop Windows-specific features
Patch: crossterm-fix-metadata.diff
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
A crossplatform terminal library for manipulating terminals.} A crossplatform terminal library for manipulating terminals.}
@ -73,28 +76,28 @@ use the "event-stream" feature of the "%{crate}" crate.
%files -n %{name}+event-stream-devel %files -n %{name}+event-stream-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+filedescriptor-devel %package -n %{name}+events-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+filedescriptor-devel %{_description} %description -n %{name}+events-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use the "filedescriptor" feature of the "%{crate}" crate. use the "events" feature of the "%{crate}" crate.
%files -n %{name}+filedescriptor-devel %files -n %{name}+events-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-core-devel %package -n %{name}+filedescriptor-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+futures-core-devel %{_description} %description -n %{name}+filedescriptor-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use the "futures-core" feature of the "%{crate}" crate. use the "filedescriptor" feature of the "%{crate}" crate.
%files -n %{name}+futures-core-devel %files -n %{name}+filedescriptor-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
@ -122,7 +125,7 @@ use the "use-dev-tty" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -1 +1 @@
SHA512 (crossterm-0.26.1.crate) = 598431aee3067c071cc2561def7055f15f5bb91c70246f975d6227bb385fe8b1aa6b59096c465a92e09c8a934bd2a6d45790edc453d5c820a96b8fae1f66e81b SHA512 (crossterm-0.27.0.crate) = b7b2b7d8affd845902e0dfa06edbcba9c7794e0839895998f39ea1b118de5251fb87c6b5de27e85c490a436b04943ff51d609cecb780674c3768c12ec401d2eb

Loading…
Cancel
Save