import rust-crossbeam-epoch-0.9.18-1.el9

i9ce changed/i9ce/rust-crossbeam-epoch-0.9.18-1.el9
MSVSphere Packaging Team 1 year ago
parent 9f323bdd17
commit 52fc24e037

2
.gitignore vendored

@ -1 +1 @@
SOURCES/crossbeam-epoch-0.9.17.crate SOURCES/crossbeam-epoch-0.9.18.crate

@ -1 +1 @@
6363a924b2573952465b29178ca2133d6030be2f SOURCES/crossbeam-epoch-0.9.17.crate 5191ef5c294dc963938807b99a6fb93a91d03cbc SOURCES/crossbeam-epoch-0.9.18.crate

@ -1,25 +0,0 @@
From 1cead3c1acf440d13bfa09a636a70531337f170d Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Mon, 9 Oct 2023 01:19:01 +0200
Subject: [PATCH] Remove redundant clone() call to fix builds with Rust 1.73+
---
src/guard.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/guard.rs b/src/guard.rs
index ba7fe1b..32c82e6 100644
--- a/src/guard.rs
+++ b/src/guard.rs
@@ -448,7 +448,7 @@ impl fmt::Debug for Guard {
/// a.load(Relaxed, epoch::unprotected());
///
/// // It's possible to create more dummy guards by calling `clone()`.
-/// let dummy = &epoch::unprotected().clone();
+/// let dummy = &epoch::unprotected();
///
/// dummy.defer(move || {
/// println!("This gets executed immediately.");
--
2.41.0

@ -1,6 +1,6 @@
--- crossbeam-epoch-0.9.17/Cargo.toml 1970-01-01T00:00:01+00:00 --- crossbeam-epoch-0.9.18/Cargo.toml 1970-01-01T00:00:01+00:00
+++ crossbeam-epoch-0.9.17/Cargo.toml 2023-12-27T20:28:23.715342+00:00 +++ crossbeam-epoch-0.9.18/Cargo.toml 2024-01-11T17:27:01.731050+00:00
@@ -48,7 +48,6 @@ @@ -42,7 +42,6 @@
alloc = [] alloc = []
default = ["std"] default = ["std"]
loom = [ loom = [
@ -8,7 +8,7 @@
"crossbeam-utils/loom", "crossbeam-utils/loom",
] ]
nightly = ["crossbeam-utils/nightly"] nightly = ["crossbeam-utils/nightly"]
@@ -57,7 +56,3 @@ @@ -51,7 +50,3 @@
"crossbeam-utils/std", "crossbeam-utils/std",
] ]

@ -1,6 +1,6 @@
--- crossbeam-epoch-0.9.17/Cargo.toml 1970-01-01T00:00:01+00:00 --- crossbeam-epoch-0.9.18/Cargo.toml 1970-01-01T00:00:01+00:00
+++ crossbeam-epoch-0.9.17/Cargo.toml 2023-12-27T20:28:39.797416+00:00 +++ crossbeam-epoch-0.9.18/Cargo.toml 2024-01-11T17:27:11.140087+00:00
@@ -47,9 +47,6 @@ @@ -41,9 +41,6 @@
[features] [features]
alloc = [] alloc = []
default = ["std"] default = ["std"]

@ -15,7 +15,7 @@
%global crate crossbeam-epoch %global crate crossbeam-epoch
Name: rust-crossbeam-epoch Name: rust-crossbeam-epoch
Version: 0.9.17 Version: 0.9.18
Release: %autorelease Release: %autorelease
Summary: Epoch-based garbage collection Summary: Epoch-based garbage collection
@ -118,6 +118,9 @@ use the "std" feature of the "%{crate}" crate.
%endif %endif
%changelog %changelog
* Thu Jan 11 2024 Fabio Valentini <decathorpe@gmail.com> - 0.9.18-1
- Update to version 0.9.18; Fixes RHBZ#2257268
* Wed Dec 27 2023 Fabio Valentini <decathorpe@gmail.com> - 0.9.17-1 * Wed Dec 27 2023 Fabio Valentini <decathorpe@gmail.com> - 0.9.17-1
- Update to version 0.9.17; Fixes RHBZ#2254355 - Update to version 0.9.17; Fixes RHBZ#2254355

Loading…
Cancel
Save