Update to 0.4.1

epel9
Josh Stone 7 years ago
parent 23ea9642dd
commit 0d5f4da34f

1
.gitignore vendored

@ -1 +1,2 @@
/crossbeam-epoch-0.4.0.crate
/crossbeam-epoch-0.4.1.crate

@ -1,53 +0,0 @@
From 02c2c5953c1ab19db697cc6916f38d93d2550116 Mon Sep 17 00:00:00 2001
From: Stjepan Glavina <stjepang@gmail.com>
Date: Fri, 16 Feb 2018 11:51:46 +0100
Subject: [PATCH] Fix failing doctests on i686 (#64)
---
src/atomic.rs | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/src/atomic.rs b/src/atomic.rs
index 0677332..d5e9bd6 100644
--- a/src/atomic.rs
+++ b/src/atomic.rs
@@ -681,8 +681,8 @@ impl<T> Owned<T> {
///
/// let o = Owned::new(0u64);
/// assert_eq!(o.tag(), 0);
- /// let o = o.with_tag(5);
- /// assert_eq!(o.tag(), 5);
+ /// let o = o.with_tag(2);
+ /// assert_eq!(o.tag(), 2);
/// ```
pub fn with_tag(self, tag: usize) -> Owned<T> {
let data = self.into_data();
@@ -985,10 +985,10 @@ impl<'g, T> Shared<'g, T> {
/// use crossbeam_epoch::{self as epoch, Atomic, Owned};
/// use std::sync::atomic::Ordering::SeqCst;
///
- /// let a = Atomic::<u64>::from(Owned::new(0u64).with_tag(5));
+ /// let a = Atomic::<u64>::from(Owned::new(0u64).with_tag(2));
/// let guard = &epoch::pin();
/// let p = a.load(SeqCst, guard);
- /// assert_eq!(p.tag(), 5);
+ /// assert_eq!(p.tag(), 2);
/// ```
pub fn tag(&self) -> usize {
let (_, tag) = decompose_data::<T>(self.data);
@@ -1007,10 +1007,10 @@ impl<'g, T> Shared<'g, T> {
/// let a = Atomic::new(0u64);
/// let guard = &epoch::pin();
/// let p1 = a.load(SeqCst, guard);
- /// let p2 = p1.with_tag(5);
+ /// let p2 = p1.with_tag(2);
///
/// assert_eq!(p1.tag(), 0);
- /// assert_eq!(p2.tag(), 5);
+ /// assert_eq!(p2.tag(), 2);
/// assert_eq!(p1.as_raw(), p2.as_raw());
/// ```
pub fn with_tag(&self, tag: usize) -> Shared<'g, T> {
--
2.16.1

@ -1,23 +0,0 @@
--- crossbeam-epoch-0.4.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ crossbeam-epoch-0.4.0/Cargo.toml 2018-02-15T14:47:09.648059+01:00
@@ -34,7 +34,7 @@
default-features = false
[dependencies.lazy_static]
-version = "0.2"
+version = "1"
optional = true
[dependencies.memoffset]
@@ -44,10 +44,9 @@
version = "0.3"
default-features = false
[dev-dependencies.rand]
-version = "0.3"
+version = "0.4"
[features]
default = ["use_std"]
-nightly = ["arrayvec/use_union"]
sanitize = []
use_std = ["lazy_static", "crossbeam-utils/use_std"]

@ -0,0 +1,9 @@
--- crossbeam-epoch-0.4.1/Cargo.toml 1969-12-31T16:00:00-08:00
+++ crossbeam-epoch-0.4.1/Cargo.toml 2018-03-22T15:06:37.880853-07:00
@@ -48,6 +48,5 @@
[features]
default = ["use_std"]
-nightly = ["arrayvec/use_union"]
sanitize = []
use_std = ["lazy_static", "crossbeam-utils/use_std"]

@ -5,7 +5,7 @@
%global crate crossbeam-epoch
Name: rust-%{crate}
Version: 0.4.0
Version: 0.4.1
Release: 1%{?dist}
Summary: Epoch-based garbage collection
@ -13,10 +13,8 @@ License: MIT or ASL 2.0
URL: https://crates.io/crates/crossbeam-epoch
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump lazy_static to 1, rand to 0.4: https://github.com/crossbeam-rs/crossbeam-epoch/pull/62
Patch0: crossbeam-epoch-0.4.0-fix-metadata.diff
# https://github.com/crossbeam-rs/crossbeam-epoch/commit/02c2c5953c1ab19db697cc6916f38d93d2550116
Patch0001: 0001-Fix-failing-doctests-on-i686-64.patch
# * no nightly features
Patch0: crossbeam-epoch-0.4.1-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -24,7 +22,7 @@ BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(arrayvec) >= 0.4.0 with crate(arrayvec) < 0.5.0)
BuildRequires: (crate(cfg-if) >= 0.1.0 with crate(cfg-if) < 0.2.0)
BuildRequires: (crate(crossbeam-utils) >= 0.2.0 with crate(crossbeam-utils) < 0.3.0)
BuildRequires: (crate(crossbeam-utils) >= 0.3.0 with crate(crossbeam-utils) < 0.4.0)
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(memoffset) >= 0.2.0 with crate(memoffset) < 0.3.0)
BuildRequires: (crate(scopeguard) >= 0.3.0 with crate(scopeguard) < 0.4.0)
@ -67,5 +65,8 @@ which use %{crate} from crates.io.
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Thu Mar 22 2018 Josh Stone <jistone@redhat.com> - 0.4.1-1
- Update to 0.4.1
* Thu Feb 15 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-1
- Initial package

@ -1 +1 @@
SHA512 (crossbeam-epoch-0.4.0.crate) = fe38d670d1aa2e153d845160ab0be7bef0c276e863ffd0f681b4c48f588d7910ee28b70c7d1417a1e15af82ab016c9243043bcbb82900b9bd9910fb711b7b1d9
SHA512 (crossbeam-epoch-0.4.1.crate) = 172e34568df9f87b5b7ff6fc69fa0b19b486d22916b8d67338f85f200fb39afbd586cc34b7d71b56e2f64c8670ce14e83f2c40bdee7be508cb5106c338a0a7d8

Loading…
Cancel
Save