Update to version 0.9.8; Fixes RHBZ#2064278

epel9
Fabio Valentini 3 years ago
parent df9fb86250
commit 046821ea92
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -18,3 +18,4 @@
/crossbeam-epoch-0.9.5.crate /crossbeam-epoch-0.9.5.crate
/crossbeam-epoch-0.9.6.crate /crossbeam-epoch-0.9.6.crate
/crossbeam-epoch-0.9.7.crate /crossbeam-epoch-0.9.7.crate
/crossbeam-epoch-0.9.8.crate

@ -1,6 +1,6 @@
--- crossbeam-epoch-0.9.7/Cargo.toml 1970-01-01T00:00:01+00:00 --- crossbeam-epoch-0.9.8/Cargo.toml 1970-01-01T00:00:01+00:00
+++ crossbeam-epoch-0.9.7/Cargo.toml 2022-02-07T23:47:08.269932+00:00 +++ crossbeam-epoch-0.9.8/Cargo.toml 2022-03-29T11:01:54.567202+00:00
@@ -58,10 +58,6 @@ @@ -60,18 +60,9 @@
[features] [features]
alloc = [] alloc = []
default = ["std"] default = ["std"]
@ -8,10 +8,9 @@
- "loom-crate", - "loom-crate",
- "crossbeam-utils/loom", - "crossbeam-utils/loom",
-] -]
nightly = [ nightly = ["crossbeam-utils/nightly"]
"crossbeam-utils/nightly", std = [
"const_fn", "alloc",
@@ -71,8 +67,3 @@
"crossbeam-utils/std", "crossbeam-utils/std",
"lazy_static", "lazy_static",
] ]

@ -1,11 +1,11 @@
# Generated by rust2rpm 20 # Generated by rust2rpm 21
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate crossbeam-epoch %global crate crossbeam-epoch
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.9.7 Version: 0.9.8
Release: %autorelease Release: %autorelease
Summary: Epoch-based garbage collection Summary: Epoch-based garbage collection
@ -19,7 +19,7 @@ Patch0: crossbeam-epoch-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Epoch-based garbage collection.} Epoch-based garbage collection.}
@ -36,9 +36,11 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-APACHE LICENSE-MIT %license %{crate_instdir}/LICENSE-APACHE
%doc CHANGELOG.md README.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -50,7 +52,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel %package -n %{name}+alloc-devel
Summary: %{summary} Summary: %{summary}
@ -62,19 +64,7 @@ This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate. use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel %files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+const_fn-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+const_fn-devel %{_description}
This package contains library source intended for building other packages which
use the "const_fn" feature of the "%{crate}" crate.
%files -n %{name}+const_fn-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+lazy_static-devel %package -n %{name}+lazy_static-devel
Summary: %{summary} Summary: %{summary}
@ -86,7 +76,7 @@ This package contains library source intended for building other packages which
use the "lazy_static" feature of the "%{crate}" crate. use the "lazy_static" feature of the "%{crate}" crate.
%files -n %{name}+lazy_static-devel %files -n %{name}+lazy_static-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly-devel %package -n %{name}+nightly-devel
Summary: %{summary} Summary: %{summary}
@ -98,7 +88,7 @@ This package contains library source intended for building other packages which
use the "nightly" feature of the "%{crate}" crate. use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel %files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
@ -110,7 +100,7 @@ This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate. use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (crossbeam-epoch-0.9.7.crate) = f6afc55b8624fd3d4f8b0fa5f949360b7e205f7f5be92c248acc102d761e8cd1facac0e40be2f507379c824ce2bfefbf6aea6e8a87eb2ba1c20f928bb9dcc0a9 SHA512 (crossbeam-epoch-0.9.8.crate) = c102e7ce9e927424f6c7c20f5eef5dee3457ef6ae3b81ab26e7dd4c787dc525610f1dcd85c3b06773b263c0835a717ce39bf35b927cea03abea62bc0a0a15624

Loading…
Cancel
Save