commit
90dd5130ca
@ -0,0 +1,21 @@
|
||||
MIT License
|
||||
|
||||
Copyright (c) 2020 David Purdum
|
||||
|
||||
Permission is hereby granted, free of charge, to any person obtaining a copy
|
||||
of this software and associated documentation files (the "Software"), to deal
|
||||
in the Software without restriction, including without limitation the rights
|
||||
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
|
||||
copies of the Software, and to permit persons to whom the Software is
|
||||
furnished to do so, subject to the following conditions:
|
||||
|
||||
The above copyright notice and this permission notice shall be included in all
|
||||
copies or substantial portions of the Software.
|
||||
|
||||
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
|
||||
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
|
||||
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
|
||||
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
|
||||
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
|
||||
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
|
||||
SOFTWARE.
|
Binary file not shown.
@ -0,0 +1,23 @@
|
||||
--- convert_case-0.4.0/Cargo.toml 2020-05-18T02:16:34+00:00
|
||||
+++ convert_case-0.4.0/Cargo.toml 2022-12-15T12:49:37.895777+00:00
|
||||
@@ -21,18 +21,14 @@
|
||||
categories = ["text-processing"]
|
||||
license = "MIT"
|
||||
repository = "https://github.com/rutrum/convert-case"
|
||||
-[profile.release]
|
||||
-lto = true
|
||||
-codegen-units = 1
|
||||
-panic = "abort"
|
||||
[dependencies.rand]
|
||||
version = "^0.7"
|
||||
optional = true
|
||||
[dev-dependencies.strum]
|
||||
-version = "0.18.0"
|
||||
+version = "0.21.0"
|
||||
|
||||
[dev-dependencies.strum_macros]
|
||||
-version = "0.18.0"
|
||||
+version = "0.21.0"
|
||||
|
||||
[features]
|
||||
random = ["rand"]
|
@ -0,0 +1,114 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate convert_case
|
||||
|
||||
Name: rust-convert_case0.4
|
||||
Version: 0.4.0
|
||||
Release: %autorelease
|
||||
Summary: Convert strings into any case
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/convert_case
|
||||
Source: %{crates_source}
|
||||
Source: https://raw.githubusercontent.com/rutrum/convert-case/master/LICENSE
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * bump strum and strum_macros from 0.18 to 0.21.0:
|
||||
# https://github.com/rutrum/convert-case/pull/3
|
||||
# * disable LTO to work around LLVM crashes on ppc64le:
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2142648
|
||||
Patch: convert_case-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Convert strings into any case.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rand-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rand-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rand" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rand-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+random-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+random-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "random" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+random-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
cp -p %{SOURCE1} LICENSE
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jan 10 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.4.0-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Fri Dec 15 2023 Michel Lind <salimma@fedoraproject.org> - 0.4.0-1
|
||||
- Initial package
|
Loading…
Reference in new issue