Initial import (console 0.14 compat package)

epel9
Fabio Valentini 3 years ago
parent 97e86e7b0b
commit 4855103917
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

4
.gitignore vendored

@ -0,0 +1,4 @@
/results_*/
/*.src.rpm
/console-0.14.1.crate

@ -1,3 +0,0 @@
# rust-console0.14
The rust-console0.14 package

@ -0,0 +1,17 @@
--- console-0.14.1/Cargo.toml 2021-03-15T00:30:45+00:00
+++ console-0.14.1/Cargo.toml 2022-01-12T13:40:52.313435+00:00
@@ -44,14 +44,3 @@
[features]
ansi-parsing = ["regex"]
default = ["unicode-width", "ansi-parsing"]
-windows-console-colors = ["ansi-parsing", "winapi-util"]
-[target."cfg(windows)".dependencies.encode_unicode]
-version = "0.3"
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["winbase", "winuser", "consoleapi", "processenv", "wincon"]
-
-[target."cfg(windows)".dependencies.winapi-util]
-version = "0.1.3"
-optional = true

@ -0,0 +1,110 @@
# Generated by rust2rpm 20
%bcond_without check
%global debug_package %{nil}
%global crate console
Name: rust-%{crate}0.14
Version: 0.14.1
Release: %autorelease
Summary: Terminal and console abstraction for Rust
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/console
Source: %{crates_source}
# Initial patched metadata
# * drop windows-specific dependencies
Patch0: console-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
%global _description %{expand:
Terminal and console abstraction for Rust.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+ansi-parsing-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ansi-parsing-devel %{_description}
This package contains library source intended for building other packages which
use the "ansi-parsing" feature of the "%{crate}" crate.
%files -n %{name}+ansi-parsing-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+regex-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-devel %{_description}
This package contains library source intended for building other packages which
use the "regex" feature of the "%{crate}" crate.
%files -n %{name}+regex-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+unicode-width-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-width-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-width" feature of the "%{crate}" crate.
%files -n %{name}+unicode-width-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (console-0.14.1.crate) = 2c85d1938faca5163dd7eede2a8a07569e536c92fd0fbc7f6e6ed91c60fa7f947f0ae101817ed943b0668c4d98ddfd3149033c83614786b5d841b19a8b011c91
Loading…
Cancel
Save