parent
c86fcd062d
commit
d5631bd5cf
@ -0,0 +1 @@
|
|||||||
|
/console-0.6.1.crate
|
@ -0,0 +1,25 @@
|
|||||||
|
--- console-0.6.1/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ console-0.6.1/Cargo.toml 2018-09-03T09:35:42.329911+02:00
|
||||||
|
@@ -24,7 +24,7 @@
|
||||||
|
version = "0.2.0"
|
||||||
|
|
||||||
|
[dependencies.lazy_static]
|
||||||
|
-version = "0.2"
|
||||||
|
+version = "1"
|
||||||
|
|
||||||
|
[dependencies.libc]
|
||||||
|
version = "0"
|
||||||
|
@@ -33,12 +33,9 @@
|
||||||
|
version = "0"
|
||||||
|
|
||||||
|
[dependencies.regex]
|
||||||
|
-version = "0.2"
|
||||||
|
+version = "1"
|
||||||
|
|
||||||
|
[dependencies.unicode-width]
|
||||||
|
version = "0.1"
|
||||||
|
[target."cfg(unix)".dependencies.termios]
|
||||||
|
-version = "0.2"
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
version = "0.3"
|
||||||
|
-features = ["winbase", "winuser", "consoleapi", "processenv", "wincon"]
|
@ -0,0 +1,68 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate console
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.6.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Terminal and console abstraction for Rust
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/console
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Bump lazy_static to 1 and regex to 1 and termios to 0.3, https://github.com/mitsuhiko/console/pull/6
|
||||||
|
# * No Windows
|
||||||
|
Patch0: console-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(clicolors-control) >= 0.2.0 with crate(clicolors-control) < 0.3.0)
|
||||||
|
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
|
||||||
|
BuildRequires: (crate(libc) >= 0.0.0 with crate(libc) < 1.0.0)
|
||||||
|
BuildRequires: (crate(parking_lot) >= 0.0.0 with crate(parking_lot) < 1.0.0)
|
||||||
|
BuildRequires: (crate(regex) >= 1.0.0 with crate(regex) < 2.0.0)
|
||||||
|
BuildRequires: (crate(termios) >= 0.3.0 with crate(termios) < 0.4.0)
|
||||||
|
BuildRequires: (crate(unicode-width) >= 0.1.0 with crate(unicode-width) < 0.2.0)
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
A terminal and console abstraction for Rust.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Sep 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.1-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue