commit
fb5b224662
Binary file not shown.
@ -0,0 +1,53 @@
|
||||
--- combine-4.6.6/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ combine-4.6.6/Cargo.toml 2022-08-10T19:32:50.511737+00:00
|
||||
@@ -127,12 +127,6 @@
|
||||
default-features = false
|
||||
package = "tokio"
|
||||
|
||||
-[dependencies.tokio-03-dep]
|
||||
-version = "0.3"
|
||||
-optional = true
|
||||
-default-features = false
|
||||
-package = "tokio"
|
||||
-
|
||||
[dependencies.tokio-dep]
|
||||
version = "1"
|
||||
optional = true
|
||||
@@ -154,10 +148,6 @@
|
||||
[dev-dependencies.bytes_05]
|
||||
version = "0.5"
|
||||
package = "bytes"
|
||||
-
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.3"
|
||||
-default-features = false
|
||||
|
||||
[dev-dependencies.futures-03-dep]
|
||||
version = "0.3.1"
|
||||
@@ -186,15 +176,6 @@
|
||||
"io-driver",
|
||||
"io-util",
|
||||
"macros",
|
||||
-]
|
||||
-package = "tokio"
|
||||
-
|
||||
-[dev-dependencies.tokio-03-dep]
|
||||
-version = "0.3"
|
||||
-features = [
|
||||
- "fs",
|
||||
- "macros",
|
||||
- "rt-multi-thread",
|
||||
]
|
||||
package = "tokio"
|
||||
|
||||
@@ -240,10 +221,3 @@
|
||||
"pin-project-lite",
|
||||
"bytes_05",
|
||||
]
|
||||
-tokio-03 = [
|
||||
- "pin-project",
|
||||
- "std",
|
||||
- "tokio-03-dep",
|
||||
- "futures-core-03",
|
||||
- "pin-project-lite",
|
||||
-]
|
@ -0,0 +1,296 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.0)
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 22
|
||||
# * tests rely on missing or removed dev-dependencies
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate combine
|
||||
|
||||
Name: rust-combine
|
||||
Version: 4.6.6
|
||||
Release: %autorelease
|
||||
Summary: Fast parser combinators on arbitrary streams with zero-copy support
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/combine
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||
# * drop features and dependencies for tokio 0.3
|
||||
Patch: combine-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Fast parser combinators on arbitrary streams with zero-copy support.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+alloc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+alloc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "alloc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+alloc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+bytes-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+bytes-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "bytes" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+bytes-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+bytes_05-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+bytes_05-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "bytes_05" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+bytes_05-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-03-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-03-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures-03" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-03-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-core-03-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-core-03-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures-core-03" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-core-03-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-io-03-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-io-03-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures-io-03" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-io-03-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+mp4-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+mp4-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "mp4" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+mp4-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+pin-project-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+pin-project-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "pin-project" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+pin-project-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+pin-project-lite-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+pin-project-lite-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "pin-project-lite" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+pin-project-lite-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+regex-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+regex-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "regex" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+regex-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-02-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-02-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-02" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-02-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-02-dep-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-02-dep-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-02-dep" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-02-dep-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-dep-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-dep-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-dep" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-dep-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-util-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-util-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-util" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-util-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 4.6.6-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Wed Aug 10 2022 Fabio Valentini <decathorpe@gmail.com> 4.6.6-1
|
||||
- Update to version 4.6.6; Fixes RHBZ#2117017
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> 4.6.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Wed May 25 2022 Fabio Valentini <decathorpe@gmail.com> 4.6.4-1
|
||||
- Update to version 4.6.4; Fixes RHBZ#2078450
|
||||
|
||||
* Sat Feb 05 2022 Fabio Valentini <decathorpe@gmail.com> 4.6.3-1
|
||||
- Update to version 4.6.3; Fixes RHBZ#2050963
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> 4.6.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Mon Dec 06 2021 Davide Cavalca <dcavalca@fedoraproject.org> 4.6.0-1
|
||||
- Initial import; Fixes: RHBZ#1982509
|
Loading…
Reference in new issue