Update to version 4.6.4; Fixes RHBZ#2078450

epel9
Fabio Valentini 3 years ago
parent 011b32890d
commit 20ff79fbcc
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,2 +1,3 @@
/combine-4.6.0.crate /combine-4.6.0.crate
/combine-4.6.3.crate /combine-4.6.3.crate
/combine-4.6.4.crate

@ -1,6 +1,6 @@
--- combine-4.6.3/Cargo.toml 1970-01-01T00:00:01+00:00 --- combine-4.6.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ combine-4.6.3/Cargo.toml 2022-02-05T11:26:30.337832+00:00 +++ combine-4.6.4/Cargo.toml 2022-05-25T13:15:54.690439+00:00
@@ -106,12 +106,6 @@ @@ -126,12 +126,6 @@
default-features = false default-features = false
package = "tokio" package = "tokio"
@ -13,20 +13,30 @@
[dependencies.tokio-dep] [dependencies.tokio-dep]
version = "1" version = "1"
optional = true optional = true
@@ -159,11 +153,6 @@ @@ -185,15 +179,6 @@
features = ["fs", "io-driver", "io-util", "macros"] "io-driver",
package = "tokio" "io-util",
"macros",
-[dev-dependencies.tokio-03-dep] -]
-version = "0.3"
-features = ["fs", "macros", "rt-multi-thread"]
-package = "tokio" -package = "tokio"
- -
[dev-dependencies.tokio-dep] -[dev-dependencies.tokio-03-dep]
version = "1" -version = "0.3"
features = ["fs", "macros", "rt", "rt-multi-thread", "io-util"] -features = [
@@ -178,4 +167,3 @@ - "fs",
std = ["memchr/use_std", "bytes", "alloc"] - "macros",
tokio = ["tokio-dep", "tokio-util/io", "futures-core-03", "pin-project-lite"] - "rt-multi-thread",
tokio-02 = ["pin-project", "std", "tokio-02-dep", "futures-core-03", "pin-project-lite", "bytes_05"] ]
-tokio-03 = ["pin-project", "std", "tokio-03-dep", "futures-core-03", "pin-project-lite"] package = "tokio"
@@ -239,10 +224,3 @@
"pin-project-lite",
"bytes_05",
]
-tokio-03 = [
- "pin-project",
- "std",
- "tokio-03-dep",
- "futures-core-03",
- "pin-project-lite",
-]

@ -1,4 +1,4 @@
# Generated by rust2rpm 20 # Generated by rust2rpm 21
# * tests rely on missing or removed dev-dependencies # * tests rely on missing or removed dev-dependencies
%bcond_with check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
@ -6,7 +6,7 @@
%global crate combine %global crate combine
Name: rust-%{crate} Name: rust-%{crate}
Version: 4.6.3 Version: 4.6.4
Release: %autorelease Release: %autorelease
Summary: Fast parser combinators on arbitrary streams with zero-copy support Summary: Fast parser combinators on arbitrary streams with zero-copy support
@ -20,7 +20,7 @@ Patch0: combine-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Fast parser combinators on arbitrary streams with zero-copy support.} Fast parser combinators on arbitrary streams with zero-copy support.}
@ -37,9 +37,10 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE %license %{crate_instdir}/LICENSE
%doc CHANGELOG.md README.md %doc %{crate_instdir}/CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -51,7 +52,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel %package -n %{name}+alloc-devel
Summary: %{summary} Summary: %{summary}
@ -63,7 +64,7 @@ This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate. use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel %files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytes-devel %package -n %{name}+bytes-devel
Summary: %{summary} Summary: %{summary}
@ -75,7 +76,7 @@ This package contains library source intended for building other packages which
use the "bytes" feature of the "%{crate}" crate. use the "bytes" feature of the "%{crate}" crate.
%files -n %{name}+bytes-devel %files -n %{name}+bytes-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytes_05-devel %package -n %{name}+bytes_05-devel
Summary: %{summary} Summary: %{summary}
@ -87,7 +88,7 @@ This package contains library source intended for building other packages which
use the "bytes_05" feature of the "%{crate}" crate. use the "bytes_05" feature of the "%{crate}" crate.
%files -n %{name}+bytes_05-devel %files -n %{name}+bytes_05-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-03-devel %package -n %{name}+futures-03-devel
Summary: %{summary} Summary: %{summary}
@ -99,7 +100,7 @@ This package contains library source intended for building other packages which
use the "futures-03" feature of the "%{crate}" crate. use the "futures-03" feature of the "%{crate}" crate.
%files -n %{name}+futures-03-devel %files -n %{name}+futures-03-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-core-03-devel %package -n %{name}+futures-core-03-devel
Summary: %{summary} Summary: %{summary}
@ -111,7 +112,7 @@ This package contains library source intended for building other packages which
use the "futures-core-03" feature of the "%{crate}" crate. use the "futures-core-03" feature of the "%{crate}" crate.
%files -n %{name}+futures-core-03-devel %files -n %{name}+futures-core-03-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-io-03-devel %package -n %{name}+futures-io-03-devel
Summary: %{summary} Summary: %{summary}
@ -123,7 +124,7 @@ This package contains library source intended for building other packages which
use the "futures-io-03" feature of the "%{crate}" crate. use the "futures-io-03" feature of the "%{crate}" crate.
%files -n %{name}+futures-io-03-devel %files -n %{name}+futures-io-03-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mp4-devel %package -n %{name}+mp4-devel
Summary: %{summary} Summary: %{summary}
@ -135,7 +136,7 @@ This package contains library source intended for building other packages which
use the "mp4" feature of the "%{crate}" crate. use the "mp4" feature of the "%{crate}" crate.
%files -n %{name}+mp4-devel %files -n %{name}+mp4-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pin-project-devel %package -n %{name}+pin-project-devel
Summary: %{summary} Summary: %{summary}
@ -147,7 +148,7 @@ This package contains library source intended for building other packages which
use the "pin-project" feature of the "%{crate}" crate. use the "pin-project" feature of the "%{crate}" crate.
%files -n %{name}+pin-project-devel %files -n %{name}+pin-project-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pin-project-lite-devel %package -n %{name}+pin-project-lite-devel
Summary: %{summary} Summary: %{summary}
@ -159,7 +160,7 @@ This package contains library source intended for building other packages which
use the "pin-project-lite" feature of the "%{crate}" crate. use the "pin-project-lite" feature of the "%{crate}" crate.
%files -n %{name}+pin-project-lite-devel %files -n %{name}+pin-project-lite-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-devel %package -n %{name}+regex-devel
Summary: %{summary} Summary: %{summary}
@ -171,7 +172,7 @@ This package contains library source intended for building other packages which
use the "regex" feature of the "%{crate}" crate. use the "regex" feature of the "%{crate}" crate.
%files -n %{name}+regex-devel %files -n %{name}+regex-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
@ -183,7 +184,7 @@ This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate. use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-devel %package -n %{name}+tokio-devel
Summary: %{summary} Summary: %{summary}
@ -195,7 +196,7 @@ This package contains library source intended for building other packages which
use the "tokio" feature of the "%{crate}" crate. use the "tokio" feature of the "%{crate}" crate.
%files -n %{name}+tokio-devel %files -n %{name}+tokio-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-02-devel %package -n %{name}+tokio-02-devel
Summary: %{summary} Summary: %{summary}
@ -207,7 +208,7 @@ This package contains library source intended for building other packages which
use the "tokio-02" feature of the "%{crate}" crate. use the "tokio-02" feature of the "%{crate}" crate.
%files -n %{name}+tokio-02-devel %files -n %{name}+tokio-02-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-02-dep-devel %package -n %{name}+tokio-02-dep-devel
Summary: %{summary} Summary: %{summary}
@ -219,7 +220,7 @@ This package contains library source intended for building other packages which
use the "tokio-02-dep" feature of the "%{crate}" crate. use the "tokio-02-dep" feature of the "%{crate}" crate.
%files -n %{name}+tokio-02-dep-devel %files -n %{name}+tokio-02-dep-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-dep-devel %package -n %{name}+tokio-dep-devel
Summary: %{summary} Summary: %{summary}
@ -231,7 +232,7 @@ This package contains library source intended for building other packages which
use the "tokio-dep" feature of the "%{crate}" crate. use the "tokio-dep" feature of the "%{crate}" crate.
%files -n %{name}+tokio-dep-devel %files -n %{name}+tokio-dep-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-util-devel %package -n %{name}+tokio-util-devel
Summary: %{summary} Summary: %{summary}
@ -243,7 +244,7 @@ This package contains library source intended for building other packages which
use the "tokio-util" feature of the "%{crate}" crate. use the "tokio-util" feature of the "%{crate}" crate.
%files -n %{name}+tokio-util-devel %files -n %{name}+tokio-util-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (combine-4.6.3.crate) = 495f9703efc2b9271dad2fdd2626aa9a1843fd3e10e63d0c8b9e42d4c7e3137a4740aa476c0206ad8dbf2683d0eeafde36f70581bdeb30299fa08e077f9183f3 SHA512 (combine-4.6.4.crate) = 2550aba009b8ab66230e7b21fd1cb5085c92bc280e31f35c9b02dc78fa138ef9b9ece0d7801473b88d11866b013c6fa3bb6e9611bdc1a7b85144e50a49829774

Loading…
Cancel
Save