Update to version 4.6.6; Fixes RHBZ#2117017

epel9 imports/e9/rust-combine-4.6.6-1.el9
Fabio Valentini 3 years ago
parent e70bb38ce8
commit 1e500b3bc7
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,3 +1,4 @@
/combine-4.6.0.crate /combine-4.6.0.crate
/combine-4.6.3.crate /combine-4.6.3.crate
/combine-4.6.4.crate /combine-4.6.4.crate
/combine-4.6.6.crate

@ -1,46 +0,0 @@
diff -Naur a/tests/support/mod.rs b/tests/support/mod.rs
--- a/tests/support/mod.rs 1969-12-31 16:00:00.000000000 -0800
+++ b/tests/support/mod.rs 2021-07-14 21:47:18.502065660 -0700
@@ -61,42 +61,6 @@
}
}
-impl<R> tokio_03_dep::io::AsyncRead for PartialAsyncRead<R>
-where
- R: tokio_03_dep::io::AsyncRead + Unpin,
-{
- fn poll_read(
- mut self: Pin<&mut Self>,
- cx: &mut task::Context<'_>,
- buf: &mut tokio_03_dep::io::ReadBuf<'_>,
- ) -> Poll<io::Result<()>> {
- match self.ops.next() {
- Some(PartialOp::Limited(n)) => {
- let len = std::cmp::min(n, buf.remaining());
- buf.initialize_unfilled();
- let mut sub_buf = buf.take(len);
- ready!(Pin::new(&mut self.inner).poll_read(cx, &mut sub_buf))?;
- let filled = sub_buf.filled().len();
- buf.advance(filled);
- Poll::Ready(Ok(()))
- }
- Some(PartialOp::Err(err)) => {
- if err == io::ErrorKind::WouldBlock {
- cx.waker().wake_by_ref();
- Poll::Pending
- } else {
- Err(io::Error::new(
- err,
- "error during read, generated by partial-io",
- ))
- .into()
- }
- }
- Some(PartialOp::Unlimited) | None => Pin::new(&mut self.inner).poll_read(cx, buf),
- }
- }
-}
-
impl<R> tokio_dep::io::AsyncRead for PartialAsyncRead<R>
where
R: tokio_dep::io::AsyncRead + Unpin,

@ -1,6 +1,6 @@
--- combine-4.6.4/Cargo.toml 1970-01-01T00:00:01+00:00 --- combine-4.6.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ combine-4.6.4/Cargo.toml 2022-05-25T13:15:54.690439+00:00 +++ combine-4.6.6/Cargo.toml 2022-08-10T19:32:50.511737+00:00
@@ -126,12 +126,6 @@ @@ -127,12 +127,6 @@
default-features = false default-features = false
package = "tokio" package = "tokio"
@ -13,7 +13,18 @@
[dependencies.tokio-dep] [dependencies.tokio-dep]
version = "1" version = "1"
optional = true optional = true
@@ -185,15 +179,6 @@ @@ -154,10 +148,6 @@
[dev-dependencies.bytes_05]
version = "0.5"
package = "bytes"
-
-[dev-dependencies.criterion]
-version = "0.3"
-default-features = false
[dev-dependencies.futures-03-dep]
version = "0.3.1"
@@ -186,15 +176,6 @@
"io-driver", "io-driver",
"io-util", "io-util",
"macros", "macros",
@ -29,7 +40,7 @@
] ]
package = "tokio" package = "tokio"
@@ -239,10 +224,3 @@ @@ -240,10 +221,3 @@
"pin-project-lite", "pin-project-lite",
"bytes_05", "bytes_05",
] ]

@ -1,22 +1,22 @@
# Generated by rust2rpm 21 # Generated by rust2rpm 22
# * tests rely on missing or removed dev-dependencies # * tests rely on missing or removed dev-dependencies
%bcond_with check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate combine %global crate combine
Name: rust-%{crate} Name: rust-combine
Version: 4.6.4 Version: 4.6.6
Release: %autorelease Release: %autorelease
Summary: Fast parser combinators on arbitrary streams with zero-copy support Summary: Fast parser combinators on arbitrary streams with zero-copy support
# Upstream license specification: MIT
License: MIT License: MIT
URL: https://crates.io/crates/combine URL: https://crates.io/crates/combine
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * drop features and dependencies for tokio 0.3 # * drop features and dependencies for tokio 0.3
Patch0: combine-fix-metadata.diff Patch: combine-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}

@ -1 +1 @@
SHA512 (combine-4.6.4.crate) = 2550aba009b8ab66230e7b21fd1cb5085c92bc280e31f35c9b02dc78fa138ef9b9ece0d7801473b88d11866b013c6fa3bb6e9611bdc1a7b85144e50a49829774 SHA512 (combine-4.6.6.crate) = ff9ef9329de2cfc103271a25ad1fcb7e478f3328843bd8a65653e80b74112728ad4a33326a58ed7ef8cf39eec7c3b797fc287295ba149ee0dccb1de9721b5819

Loading…
Cancel
Save