Update to version 1.3.1; Fixes RHBZ#2050476

epel9
Fabio Valentini 3 years ago
parent efc0e6e9df
commit eb0b7f9a86
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -17,3 +17,4 @@
/clang-sys-1.2.0.crate /clang-sys-1.2.0.crate
/clang-sys-1.2.2.crate /clang-sys-1.2.2.crate
/clang-sys-1.3.0.crate /clang-sys-1.3.0.crate
/clang-sys-1.3.1.crate

@ -1,10 +1,10 @@
--- clang-sys-1.3.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- clang-sys-1.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ clang-sys-1.3.0/Cargo.toml 2021-11-09T19:49:53.803269+00:00 +++ clang-sys-1.3.1/Cargo.toml 2022-02-04T23:11:52.843635+00:00
@@ -20,6 +20,7 @@ @@ -20,6 +20,7 @@
readme = "README.md" readme = "README.md"
license = "Apache-2.0" license = "Apache-2.0"
repository = "https://github.com/KyleMayes/clang-sys" repository = "https://github.com/KyleMayes/clang-sys"
+exclude = ["/clippy.toml"] +exclude = ["/clippy.toml"]
[package.metadata.docs.rs] [package.metadata.docs.rs]
features = ["clang_11_0", "runtime"] features = ["clang_13_0", "runtime"]
[dependencies.glob] [dependencies.glob]

@ -1,11 +1,11 @@
# Generated by rust2rpm 18 # Generated by rust2rpm 20
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate clang-sys %global crate clang-sys
Name: rust-%{crate} Name: rust-%{crate}
Version: 1.3.0 Version: 1.3.1
Release: %autorelease Release: %autorelease
Summary: Rust bindings for libclang Summary: Rust bindings for libclang
@ -18,9 +18,6 @@ Source: %{crates_source}
Patch0: clang-sys-fix-metadata.diff Patch0: clang-sys-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging
@ -35,12 +32,12 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE.txt %license LICENSE.txt
%doc README.md CHANGELOG.md %doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
@ -50,8 +47,8 @@ Requires: clang-devel >= 3.5
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -63,8 +60,8 @@ Requires: clang-devel >= 10.0
%description -n %{name}+clang_10_0-devel %{_description} %description -n %{name}+clang_10_0-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_10_0" feature of "%{crate}" crate. use the "clang_10_0" feature of the "%{crate}" crate.
%files -n %{name}+clang_10_0-devel %files -n %{name}+clang_10_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -76,8 +73,8 @@ Requires: clang-devel >= 11.0
%description -n %{name}+clang_11_0-devel %{_description} %description -n %{name}+clang_11_0-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_11_0" feature of "%{crate}" crate. use the "clang_11_0" feature of the "%{crate}" crate.
%files -n %{name}+clang_11_0-devel %files -n %{name}+clang_11_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -89,8 +86,8 @@ Requires: clang-devel >= 12.0
%description -n %{name}+clang_12_0-devel %{_description} %description -n %{name}+clang_12_0-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_12_0" feature of "%{crate}" crate. use the "clang_12_0" feature of the "%{crate}" crate.
%files -n %{name}+clang_12_0-devel %files -n %{name}+clang_12_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -102,8 +99,8 @@ Requires: clang-devel >= 13.0
%description -n %{name}+clang_13_0-devel %{_description} %description -n %{name}+clang_13_0-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_13_0" feature of "%{crate}" crate. use the "clang_13_0" feature of the "%{crate}" crate.
%files -n %{name}+clang_13_0-devel %files -n %{name}+clang_13_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -115,8 +112,8 @@ Requires: clang-devel >= 3.5
%description -n %{name}+clang_3_5-devel %{_description} %description -n %{name}+clang_3_5-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_3_5" feature of "%{crate}" crate. use the "clang_3_5" feature of the "%{crate}" crate.
%files -n %{name}+clang_3_5-devel %files -n %{name}+clang_3_5-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -128,8 +125,8 @@ Requires: clang-devel >= 3.6
%description -n %{name}+clang_3_6-devel %{_description} %description -n %{name}+clang_3_6-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_3_6" feature of "%{crate}" crate. use the "clang_3_6" feature of the "%{crate}" crate.
%files -n %{name}+clang_3_6-devel %files -n %{name}+clang_3_6-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -141,8 +138,8 @@ Requires: clang-devel >= 3.7
%description -n %{name}+clang_3_7-devel %{_description} %description -n %{name}+clang_3_7-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_3_7" feature of "%{crate}" crate. use the "clang_3_7" feature of the "%{crate}" crate.
%files -n %{name}+clang_3_7-devel %files -n %{name}+clang_3_7-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -154,8 +151,8 @@ Requires: clang-devel >= 3.8
%description -n %{name}+clang_3_8-devel %{_description} %description -n %{name}+clang_3_8-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_3_8" feature of "%{crate}" crate. use the "clang_3_8" feature of the "%{crate}" crate.
%files -n %{name}+clang_3_8-devel %files -n %{name}+clang_3_8-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -167,8 +164,8 @@ Requires: clang-devel >= 3.9
%description -n %{name}+clang_3_9-devel %{_description} %description -n %{name}+clang_3_9-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_3_9" feature of "%{crate}" crate. use the "clang_3_9" feature of the "%{crate}" crate.
%files -n %{name}+clang_3_9-devel %files -n %{name}+clang_3_9-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -180,8 +177,8 @@ Requires: clang-devel >= 4.0
%description -n %{name}+clang_4_0-devel %{_description} %description -n %{name}+clang_4_0-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_4_0" feature of "%{crate}" crate. use the "clang_4_0" feature of the "%{crate}" crate.
%files -n %{name}+clang_4_0-devel %files -n %{name}+clang_4_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -193,8 +190,8 @@ Requires: clang-devel >= 5.0
%description -n %{name}+clang_5_0-devel %{_description} %description -n %{name}+clang_5_0-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_5_0" feature of "%{crate}" crate. use the "clang_5_0" feature of the "%{crate}" crate.
%files -n %{name}+clang_5_0-devel %files -n %{name}+clang_5_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -206,8 +203,8 @@ Requires: clang-devel >= 6.0
%description -n %{name}+clang_6_0-devel %{_description} %description -n %{name}+clang_6_0-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_6_0" feature of "%{crate}" crate. use the "clang_6_0" feature of the "%{crate}" crate.
%files -n %{name}+clang_6_0-devel %files -n %{name}+clang_6_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -219,8 +216,8 @@ Requires: clang-devel >= 7.0
%description -n %{name}+clang_7_0-devel %{_description} %description -n %{name}+clang_7_0-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_7_0" feature of "%{crate}" crate. use the "clang_7_0" feature of the "%{crate}" crate.
%files -n %{name}+clang_7_0-devel %files -n %{name}+clang_7_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -232,8 +229,8 @@ Requires: clang-devel >= 8.0
%description -n %{name}+clang_8_0-devel %{_description} %description -n %{name}+clang_8_0-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_8_0" feature of "%{crate}" crate. use the "clang_8_0" feature of the "%{crate}" crate.
%files -n %{name}+clang_8_0-devel %files -n %{name}+clang_8_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -245,8 +242,8 @@ Requires: clang-devel >= 9.0
%description -n %{name}+clang_9_0-devel %{_description} %description -n %{name}+clang_9_0-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "clang_9_0" feature of "%{crate}" crate. use the "clang_9_0" feature of the "%{crate}" crate.
%files -n %{name}+clang_9_0-devel %files -n %{name}+clang_9_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -257,8 +254,8 @@ BuildArch: noarch
%description -n %{name}+libloading-devel %{_description} %description -n %{name}+libloading-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "libloading" feature of "%{crate}" crate. use the "libloading" feature of the "%{crate}" crate.
%files -n %{name}+libloading-devel %files -n %{name}+libloading-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -269,8 +266,8 @@ BuildArch: noarch
%description -n %{name}+runtime-devel %{_description} %description -n %{name}+runtime-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "runtime" feature of "%{crate}" crate. use the "runtime" feature of the "%{crate}" crate.
%files -n %{name}+runtime-devel %files -n %{name}+runtime-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -281,8 +278,8 @@ BuildArch: noarch
%description -n %{name}+static-devel %{_description} %description -n %{name}+static-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "static" feature of "%{crate}" crate. use the "static" feature of the "%{crate}" crate.
%files -n %{name}+static-devel %files -n %{name}+static-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

@ -1 +1 @@
SHA512 (clang-sys-1.3.0.crate) = 80c78c53a877cd8208730885214c135dd65a208cfd047dba7595283bbeec266f4d39cd1e0b3c2c69a474569ba68e4db93636e31a77c350d7bb2337e06ee7cb74 SHA512 (clang-sys-1.3.1.crate) = aeea37957f7e9a7ecc862f56c6492b68b57217d1a893d3978f5d48d5ef9f80cefa8c52604d7201b9c96402d87ca43ba694890b0bc849d4d623f74ea009ce45bb

Loading…
Cancel
Save